Bug 1295904 - Six failing unittests on ironic component test Jenkins build
Six failing unittests on ironic component test Jenkins build
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: ---
: 8.0 (Liberty)
Assigned To: Lucas Alvares Gomes
Toure Dunnon
: Automation, AutomationBlocker, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 13:23 EST by Harry Rybacki
Modified: 2016-09-06 12:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-06 12:20:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Console output from build (14.18 KB, text/plain)
2016-01-05 13:23 EST, Harry Rybacki
no flags Details

  None (edit)
Description Harry Rybacki 2016-01-05 13:23:38 EST
Created attachment 1111922 [details]
Console output from build

Description of problem:
There are currently six failing unittests for the ironic component test build[1] 

Version-Release number of selected component (if applicable):


How reproducible:
Easily

Steps to Reproduce:
1. Navigate to the internal Jenkins gerrit manual trigger page[2]
2. Enter 'change:62635' as your query
3. Select the radio box for the change
4. Click the 'trigger selected' button
5. Click the 'rhos-unittest-gerrit-ironic-rhel-7.2' link to the build that was kicked off.
6. (Once the build has begun) click the 'console output' button

Actual results:
1. Build is successful and output indicates all unittests passed.

Expected results:
1. Build fails and six unittests fail e.g. build 15[3].


Additional info:

[1] - https://rhos-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/rhos-unittest-gerrit-ironic-rhel-7.2/
[2] - https://rhos-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/gerrit_manual_trigger/
[3] - https://rhos-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/rhos-unittest-gerrit-ironic-rhel-7.2/15/console
Comment 2 Lucas Alvares Gomes 2016-07-06 05:23:58 EDT
Hi,

The tests seems to be fixed now.

As a note, we've started working on adding Ironic to octario [0], OSP7 and OSP8 is already up and running (9 is on the way).

[0] https://github.com/redhat-openstack/octario/tree/master/components_config/
Comment 3 Dmitry Tantsur 2016-09-06 12:20:02 EDT
Hi! Judging by comment 2 we can close this bug. Please feel free to reopen if something else has to be done.

Note You need to log in before you can comment on or make changes to this bug.