Bug 1295913 - gnuplot plots all black
gnuplot plots all black
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: octave (Show other bugs)
23
All All
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 13:47 EST by Thomas Sailer
Modified: 2016-04-13 16:23 EDT (History)
8 users (show)

See Also:
Fixed In Version: octave-4.0.1-6.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-13 16:23:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Sailer 2016-01-05 13:47:44 EST
Description of problem:
gnuplot plots printed into eps or pdf files are all black

Version-Release number of selected component (if applicable):
octave-4.0.0-8.fc23.x86_64

How reproducible:
always

Steps to Reproduce:
1.
$ octave --no-gui
>> graphics_toolkit gnuplot
>> plot(sin(0:0.1:6.28))
>> print -dpdf x.pdf

2.
$ evince x.pdf


Actual results:
plot area is completely black

Expected results:
sinus curve


Additional info:
See this upstream bug report.
http://savannah.gnu.org/bugs/?42838

This changeset fixes the issue:
http://hg.savannah.gnu.org/hgweb/octave/rev/c7d881aec36c
Comment 1 Fedora Admin XMLRPC Client 2016-01-20 09:36:26 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Orion Poplawski 2016-04-04 16:21:27 EDT
Please test https://bodhi.fedoraproject.org/updates/FEDORA-2016-f2a69b7ba7 - 42838 is not listed in the release notes, but I would have expected it to be fixed.
Comment 3 Thomas Sailer 2016-04-05 17:42:46 EDT
works for me, thanks!
Comment 4 Fedora Update System 2016-04-05 17:56:45 EDT
octave-4.0.1-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f2a69b7ba7
Comment 5 Fedora Update System 2016-04-11 09:48:27 EDT
octave-4.0.1-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3f54ef2461
Comment 6 Fedora Update System 2016-04-13 05:28:15 EDT
octave-4.0.1-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3f54ef2461
Comment 7 Fedora Update System 2016-04-13 16:23:10 EDT
octave-4.0.1-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.