Bug 1296047 - [rsdl] allocation policy and format are missing for VM and template import from export domain
[rsdl] allocation policy and format are missing for VM and template import fr...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RestAPI (Show other bugs)
3.6.2
x86_64 Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.2
: 3.6.2
Assigned To: Amit Aviram
Elad
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 04:48 EST by Elad
Modified: 2016-03-10 02:25 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:04:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: planning_ack+
tnisan: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51429 master MERGED restapi: missing RSDL fields re: import vms 2016-01-10 03:17 EST
oVirt gerrit 51578 ovirt-engine-3.6 MERGED restapi: missing RSDL fields re: import vms 2016-01-10 03:53 EST
oVirt gerrit 51579 ovirt-engine-3.6.2 MERGED restapi: missing RSDL fields re: import vms 2016-01-10 04:07 EST

  None (edit)
Description Elad 2016-01-06 04:48:22 EST
Description of problem:
In rsdl, there is no explanation regarding the disk allocation policy and format for VM and template import from export domain.
This options were introduced as part of the fix for BZ#998607.

Version-Release number of selected component (if applicable):
rhevm-restapi-3.6.2-0.1.el6.noarch



Additional info:

<link href="/api/storagedomains/{storagedomain:id}/vms/{vm:id}/import" rel="import">

<link href="/api/storagedomains/{storagedomain:id}/templates/{template:id}/import" rel="import">
Comment 1 Elad 2016-01-14 07:45:27 EST
Sparse and format were updated only for VM import in rsdl. Template import still missing them. Re-opening. 

Checked using rhevm-3.6.2.5-0.1.el6.noarch
Comment 2 Red Hat Bugzilla Rules Engine 2016-01-14 07:45:29 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Elad 2016-01-14 08:34:00 EST
Amit, I'm sorry, I don't know why I was so sure it is relevant for templates. 
BZ #998607 relates only to VM import. Therefore, this bug is fixed correctly, verifying.


Checked using rhevm-3.6.2.5-0.1.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.