Bug 1296227 - Provide better error message when adding infrastructure provider
Provide better error message when adding infrastructure provider
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: cfme-future
Assigned To: Oved Ourfali
Shveta
infra:provider
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 11:15 EST by Jeff Warnica
Modified: 2017-08-21 09:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-21 09:04:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Warnica 2016-01-06 11:15:36 EST
Description of problem:

When attempting to validate/add a new infrastructure provider, and the host name is incorrect, it displays the misleading message "Credential validation was not successful: Login failed due to a bad username or password."

evm.log actually helps:  
...... ERROR -- : <RHEVM> Ovirt::Service#resource_get: class = SocketError, message=getaddrinfo: Name or service not known, URI=.....

Suggest that UI relays truthful/helpful error message.
Comment 2 Greg Blomquist 2016-02-19 15:27:07 EST
Oved, can you take a look at this?  I'm guessing that the error message that's logged to evm.log is getting lost before it hits the UI.  It would be nice to be able to carry that message forward to the UI.
Comment 3 Chris Pelland 2017-08-21 09:04:42 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.