Bug 1296247 - Missing multi-language support on live ISOs built in Fedora 23 Cloud
Missing multi-language support on live ISOs built in Fedora 23 Cloud
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: langtable (Show other bugs)
23
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Mike FABIAN
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 12:20 EST by Striker Leggette
Modified: 2016-01-06 12:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-06 12:29:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Striker Leggette 2016-01-06 12:20:13 EST
Description of problem:
 - When building Live ISOs on Fedora 23 Cloud, the resulting images have only English support.  This was not the case on Fedora 22 Cloud.

Version-Release number of selected component (if applicable):


How reproducible:
 - Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
 - Live ISOs have all language support.

Additional info:
 - I have tried installing the missing RPMs between Fedora 22 Cloud and Fedora 23 Cloud with no change in behavior.
 - I have also tried upgrading Fedora 22 Cloud to Fedora 23 Cloud which causes the newly built live ISOs to lose multi-language support.
 - Images built on Fedora 23 Server have multi-language support.
Comment 1 Striker Leggette 2016-01-06 12:24:00 EST
This just in:

[12:10] <striker> maxamillion: I have tried installing the missing RPMs between F22C and F23C, upgrading F22C to F23C, neither change anything
[12:12] <maxamillion> striker: that's odd
[12:12] <striker> it is odd indeeeeeed
[12:13] <maxamillion> nirik: so striker said that F22 Cloud has all the language support but F23 is lacking ... any ideas? could it be a comps change? $other?
[12:14] <nirik> dunno. ask someone in the cloud sig? they are meeting now I think.
[12:17] <maxamillion> nirik: indeed we are :)
[12:17] <nirik> might be related to https://bugzilla.redhat.com/show_bug.cgi?id=1051816 and dnf-langppacks.
[12:17] <nirik> but beats me.
[12:17] * nirik goes back to trying to read email
[12:18] <maxamillion> nirik: rgr, thanks
[12:20] <striker> https://bugzilla.redhat.com/show_bug.cgi?id=1296247
[12:22] <dgilmore> maxamillion: it was intentionally removed
Comment 2 Striker Leggette 2016-01-06 12:29:14 EST
[12:26] <dgilmore> striker: echo '%_install_langs C:en:en_US:en_US.UTF-8' >> /etc/rpm/macros.image-language-conf
[12:26] <dgilmore> you will need to undo that
[12:26] <dgilmore> and then reinstall all the packages

Note You need to log in before you can comment on or make changes to this bug.