Bug 129629 - Top fails to show CPU hog
Summary: Top fails to show CPU hog
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: procps   
(Show other bugs)
Version: 2
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Karel Zak
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-11 03:22 UTC by Sam Williams
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-07 09:27:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sam Williams 2004-08-11 03:22:03 UTC
Description of problem:
I have been using an RSS aggregator called liferea. Its built with
python. Occasionally, it will go out to lunch and start consuming
large quantities of cpu. Gkrellm and the CPU panel app show the
utilization going up. If I use the top command I see what looks to be
an unused system. It doesn't register what the other utilities see. It
looks like a very quiet and unused system.


Version-Release number of selected component (if applicable):
top uses procps version 3.2.0

How reproducible:
When it dies its consistent. Haven't figure out how to cause liferea
to break. So far this is the only program that demonstrates this
inability. 

Steps to Reproduce:
1. Fire up liferea
2. Wait til CPU starts going up 
3. pop open top
  
Actual results:
Top doesn't register the liferea process consuming all the cpu.

Expected results:
To see the top process being liferea or python, since liferea is
python code. But I see neither


Additional info:

Comment 1 Rik van Riel 2004-09-27 21:48:21 UTC
Does liferea use threads ?

If you switch on display of all threads in top, do things work the way
they should ?

Comment 2 Albert Cahalan 2004-10-23 16:57:22 UTC
should be fixed with the 2.6.10 kernel


Note You need to log in before you can comment on or make changes to this bug.