Bug 1296332 - [DOCS] [SME] Use command to change default /etc/sysconfig/docker
[DOCS] [SME] Use command to change default /etc/sysconfig/docker
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Ashley Hardin
Gan Huang
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 17:12 EST by Peter Larsen
Modified: 2016-08-02 09:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-02 09:24:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Larsen 2016-01-06 17:12:38 EST
Document URL: https://docs.openshift.com/enterprise/3.1/install_config/install/prerequisites.html#software-prerequisites

Section Number and Name: Installing Docker (2)

Describe the issue: 

Give the user a simple command to run to change the default configuration file. This would allow the user to easily script a complete install from a Kickstart or cloud-init setup.

Suggestions for improvement: 

Add a command like this:
sed -i '/OPTIONS=.*/c\OPTIONS="--selinux-enabled --insecure-registry 172.30.0.0/16"' /etc/sysconfig/docker

to the section.

Additional information:
Comment 1 Peter Larsen 2016-05-18 22:25:16 EDT
It looks like the ansible installer in 3.2 adds this entry now, so it's no longer a requirement pre-install?
Comment 3 Ashley Hardin 2016-07-14 14:00:03 EDT
Work in progress:
https://github.com/openshift/openshift-docs/pull/2504
Comment 4 Ashley Hardin 2016-07-14 14:05:49 EDT
@Peter Please review my first pass at this: 
https://github.com/openshift/openshift-docs/pull/2504
Based on your previous comment, I labeled this edit for OSE 3.1, not 3.2.
Comment 5 Peter Larsen 2016-07-14 16:31:28 EDT
Only the "advanced installer" automatically changes /etc/sysconfig/docker - the "quick install" does not. There are quite a few things in the installation guide today which is only required if you use the quick-installer - so if the assumption is tha the guide only applies to customers using the quick install option, then we still need something to help out there. 

I would suggest making sure that features implemented automatically with the advanced installer gets added to the quick-installer, so post-install a user will be at the same point regardless of installation method.
Comment 6 Ashley Hardin 2016-07-19 13:01:07 EDT
@Peter Thank you! I made some edits to this section and will revisit the installation section (Quick vs Advanced Installation methods) outside of this PR.
Comment 7 Gan Huang 2016-07-28 06:01:19 EDT
Per https://bugzilla.redhat.com/show_bug.cgi?id=1317755, --insecure-registry 172.30.0.0/16 will be added automatically to /etc/sysconfig/docker when great than openshift-ansible-3.0.88-1.git.0.31c3daf.el7.

And currently in 3.0/3.1/3.2/3.3 all should have this change as all openshift-ansible > 3.0.88.
 
@Ashley, there is no need to make any other edits IMO (Both advanced/quick installer will add "--insecure-registry 172.30.0.0/16" automatically in 3.0/3.1/3.2/3.3).
Comment 8 openshift-github-bot 2016-07-28 09:57:25 EDT
Commits pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/9315ae42c10995f20bcb09f387845263dda5a096
Bug 1296332, added directions on changing the default configuration file in the Installing Docker section

https://github.com/openshift/openshift-docs/commit/abc933dad2ca5dc78f7a91f9bb94bb648b4a2192
Merge pull request #2504 from ahardin-rh/software-prerequisites

Bug 1296332, added directions on changing the default config file in the Installing Docker section
Comment 9 Ashley Hardin 2016-07-28 09:57:59 EDT
@Gan- Thanks!

Note You need to log in before you can comment on or make changes to this bug.