Bug 1296346 - SELinux is preventing cups-pk-helper- from 'unlink' accesses on the lnk_file 568d940166451.
SELinux is preventing cups-pk-helper- from 'unlink' accesses on the lnk_file ...
Status: CLOSED DUPLICATE of bug 1296349
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:8043a57ca01e7fea07a09fdf3b6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 18:42 EST by Joachim Frieben
Modified: 2016-01-07 09:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-07 09:09:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2016-01-06 18:42:17 EST
Description of problem:
SELinux is preventing cups-pk-helper- from 'unlink' accesses on the lnk_file 568d940166451.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that cups-pk-helper- should be allowed unlink access on the 568d940166451 lnk_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep cups-pk-helper- /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:cupsd_config_t:s0-s0:c0.c1023
Target Context                system_u:object_r:tmpfs_t:s0
Target Objects                568d940166451 [ lnk_file ]
Source                        cups-pk-helper-
Source Path                   cups-pk-helper-
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-164.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.4.0-0.rc8.git0.1.fc24.x86_64 #1
                              SMP Mon Jan 4 17:13:26 UTC 2016 x86_64 x86_64
Alert Count                   2
First Seen                    2016-01-06 23:23:26 CET
Last Seen                     2016-01-06 23:24:01 CET
Local ID                      29db2b1f-c144-4bf5-8287-aa3420f6ca08

Raw Audit Messages
type=AVC msg=audit(1452119041.428:599): avc:  denied  { unlink } for  pid=2528 comm="cups-pk-helper-" name="568d940166451" dev="tmpfs" ino=63359 scontext=system_u:system_r:cupsd_config_t:s0-s0:c0.c1023 tcontext=system_u:object_r:tmpfs_t:s0 tclass=lnk_file permissive=1


Hash: cups-pk-helper-,cupsd_config_t,tmpfs_t,lnk_file,unlink

Version-Release number of selected component:
selinux-policy-3.13.1-164.fc24.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.4.0-0.rc8.git0.1.fc24.x86_64
type:           libreport
Comment 1 Daniel Walsh 2016-01-07 09:09:03 EST

*** This bug has been marked as a duplicate of bug 1296349 ***

Note You need to log in before you can comment on or make changes to this bug.