Bug 129636 - All Virtual Network Interfaces stop when stopping the first virtual interface initiated
Summary: All Virtual Network Interfaces stop when stopping the first virtual interface...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: net-tools   
(Show other bugs)
Version: 2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Radek Vokal
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-11 08:52 UTC by Mark Van-Kerro
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 1.60-55
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-20 11:08:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Van-Kerro 2004-08-11 08:52:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
SV1; .NET CLR 1.1.4322)

Description of problem:
When I have multiple virtual network interfaces up and running and 
want to down a particular interface, this works fine unless you down 
the first virtual interface that starts. In the case of shutting down 
this it shutsdown all virtual interfaces.

This only happens when the virtual interfaces are assigned different 
IP addresses on the same network / subnet

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create several virtual network interfaces (E.G. eth0:1, eth0:2, 
eth0:3)
2.Start them individually in numerical order (so that eth0:1 starts 
first)
3.Once all virtual interfaces are up, shut down the first virtual 
interface started (E.G. eth0:1
    

Actual Results:  All virtual interfaces shutdown

Expected Results:  only the interface intructed should have shutdown

Additional info:

This happen on multiple interfaces and only affects virtual 
interfaces on the same network.

Not that you would do this, but to prove a point

E.G. eth0:1 addr 172.0.0.10
     eth0:2 addr 10.0.0.10
     eth0:3 addr 10.0.0.11
     eth0:4 addr 10.0.0.12

eth0:1 has not effect on 0:2,0:3,0:4. However 2,3,4 will all shutdown 
if the first virtual interface started shutsdown. This could be any 
of them.

Comment 1 Radek Vokal 2004-09-08 09:03:23 UTC
Didn't appear with 

# ifconfig --version
net-tools 1.60
ifconfig 1.42 (2001-04-13)

Can you check with rawhide version?

Comment 2 Christophe Quintard 2004-11-19 14:46:54 UTC
Exactly the same problem with redhat7.2 and redhat3.0WS.
The problem does not appear with redhat7.3 or redhat3.0AS.


Comment 3 Francois Richard 2004-11-22 14:47:03 UTC
Same problem with Redhat 9.0
Same problem with Fedora Core 1, 2 and 3
Same problem also on Suse 9.0

For every distrib:
$ ifconfig --version
net-tools 1.60
ifconfig 1.42 (2001-04-13)

Comment 4 Radek Vokal 2005-07-20 11:08:07 UTC
The problem is fixed in rawhide net-tools-1.60-55


Note You need to log in before you can comment on or make changes to this bug.