Bug 1296386 - "Filter Failed" when printing anything on Fedora 23
"Filter Failed" when printing anything on Fedora 23
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 22:27 EST by Alphakarem
Modified: 2016-01-08 17:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-08 17:29:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error Log From system-config-printer troubleshooter (63.48 KB, text/plain)
2016-01-06 22:27 EST, Alphakarem
no flags Details
journalctl log (81.62 KB, text/plain)
2016-01-07 09:42 EST, Alphakarem
no flags Details

  None (edit)
Description Alphakarem 2016-01-06 22:27:06 EST
Created attachment 1112329 [details]
Error Log From system-config-printer troubleshooter

Description of problem:
When trying to print on Fedora 23 to a Cups Print server n matter what the app is or even from the test page button, it fails with " Filter Failed"

Version-Release number of selected component (if applicable):
CUPS 2.1.2 ... Client ( Fedora 23 )
CUPS 1.7.5 ... Print Server ( Raspbian Latest )

How reproducible:
Try to print from the test page button or any file.

Steps to Reproduce:
1.
2.
3.

Actual results:
Filter Failed.

Expected results:
It should work.

Additional info:
The same Print server have been validated using Linux Mint latest and Windows * and Windows 10 and works perfectly. Issue is limited to Fedora 23 only.

Printer in Question is HP Photosmart C7200 Series installed on The print server with hp Driver hplip 3.15.1.

Attached are is the error log.
Comment 1 Jiri Popelka 2016-01-07 04:33:51 EST
Thanks,

due to bug #1293930 I need you to obtain the cupsd log manually according to https://fedoraproject.org/wiki/How_to_debug_printing_problems#Getting_debug_information_by_other_means
Comment 2 Alphakarem 2016-01-07 09:42 EST
Created attachment 1112473 [details]
journalctl log
Comment 3 Jiri Popelka 2016-01-07 09:52:33 EST
hmm, there's really just 'Filter failed' without any context, strange
Comment 4 Alphakarem 2016-01-07 11:21:38 EST
Yea that's what I thought. Nothing to go on. I wonder if my Kernel version has something to do with this  Currently running 4.4.0-0.rc6.git1.2.fc24.x86_64.
Comment 5 Tim Waugh 2016-01-08 05:07:01 EST
What 'journalctl' command line did you use? Just 'journalctl -u cups'?

FWIW, I've updated the wiki page because CUPS_JOB_ID is no longer used for the journal metadata; it's now JID.
Comment 6 Alphakarem 2016-01-08 17:29:06 EST
Apparently The Printer was on it's last breath, after the successful test it died completely. Closing as it's most likely a hardware issue.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.