Bug 1296477 - After unlocking screen applications do not respond to input
After unlocking screen applications do not respond to input
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 05:44 EST by Petri Pennanen
Modified: 2016-01-08 03:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-08 03:00:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from journalctl -p err -b -1 (2.49 KB, text/plain)
2016-01-07 05:44 EST, Petri Pennanen
no flags Details
lspci output (17.82 KB, text/plain)
2016-01-07 05:44 EST, Petri Pennanen
no flags Details
dmidecode output (14.25 KB, text/plain)
2016-01-07 05:45 EST, Petri Pennanen
no flags Details

  None (edit)
Description Petri Pennanen 2016-01-07 05:44:10 EST
Created attachment 1112405 [details]
Output from journalctl -p err -b -1

Description of problem:
After unlocking the screen all applications other than Gnome Shell stop responding to input. Selecting and clicking widgets does not work. Typing in applications does not work. Gnome Shell still responds to mouse input, but does not appear to respond to keyboard input. Even if a new application is launched, it does not respond to input. 

Version-Release number of selected component (if applicable):
Name        : gnome-session
Arch        : x86_64
Epoch       : 0
Version     : 3.18.1.2
Release     : 2.fc23

Name        : gnome-shell
Arch        : x86_64
Epoch       : 0
Version     : 3.18.3
Release     : 1.fc23

Name        : xorg-x11-server-Xorg
Arch        : x86_64
Epoch       : 0
Version     : 1.18.0
Release     : 2.fc23


How reproducible:
Happens roughly every fifth time the screen is unlocked.

Steps to Reproduce:
1. Lock the screen
2. Unlock the screen 
3. Try to type in an application, or select something with the mouse pointer

Actual results:
The application window does not change or respond to input.

Expected results:
Normal response from application.

Additional info:
The system is a Lenovo L540 laptop, with a secondary screen attached.

See attached log lines regarding gnome-session-binary (the timing matches the input freeze).
Comment 1 Petri Pennanen 2016-01-07 05:44 EST
Created attachment 1112407 [details]
lspci output
Comment 2 Petri Pennanen 2016-01-07 05:45 EST
Created attachment 1112408 [details]
dmidecode output
Comment 3 Petri Pennanen 2016-01-08 03:00:06 EST
It looks like the behaviour was triggered by the gnome-pomodoro extension. The same issue has been reported in the gnome-pomodoro issue tracker and the GNOME bugzilla: 

https://github.com/codito/gnome-pomodoro/issues/190
https://bugzilla.gnome.org/show_bug.cgi?id=754102

I am closing this, since it is known upstream.

Note You need to log in before you can comment on or make changes to this bug.