Bug 1296524 - perl-Math-PlanePath-121-1.fc24 FTBFS: t/bigfloat.t test fails
perl-Math-PlanePath-121-1.fc24 FTBFS: t/bigfloat.t test fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Math-PlanePath (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On: 1299583
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 07:32 EST by Petr Pisar
Modified: 2016-01-19 12:12 EST (History)
3 users (show)

See Also:
Fixed In Version: perl-Math-PlanePath-122-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 12:12:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2016-01-07 07:32:40 EST
perl-Math-PlanePath-121-1.fc24 fails to build in F24 because a test fails:

t/BetaOmeta.t ................... ok
# Math::BigFloat version 1.999714
# Math::BigInt version 1.999714
Use of uninitialized value in new at t/bigfloat.t line 189.
# +inf is inf
# -inf is -inf
# nan is NaN
# Saw 1 warning(s):
# (Devel::StackTrace not available for backtrace)
# Exit code 1 for warnings
t/bigfloat.t .................... 
Dubious, test returned 1 (wstat 256, 0x100)

Difference between working and failing build root:

        perl-Math-BigInt 	1.9997.10-1.fc24 	> 	1.9997.14-1.fc24
	perl-podlators 	4.03-1.fc24 	> 	4.04-1.fc24
	systemtap-sdt-devel 	3.0-0.20151214git... 	> 	3.0-0.20160104git...
	device-mapper-libs 	1.02.113-1.fc24 	> 	1.02.114-1.fc24
	device-mapper 	1.02.113-1.fc24 	> 	1.02.114-1.fc24

Note You need to log in before you can comment on or make changes to this bug.