Bug 129658 - gnome-panel continuously dies on login
gnome-panel continuously dies on login
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-11 11:44 EDT by James Laska
Modified: 2013-09-02 01:58 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.7.91.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 06:58:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
panel.strace (162.05 KB, text/plain)
2004-08-11 11:46 EDT, James Laska
no flags Details
panel.debuginfo (6.98 KB, text/plain)
2004-08-11 11:46 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2004-08-11 11:44:43 EDT
# TREE rawhide-latest (as of Aug 08, 2004)
# RPM  gnome-panel-2.7.90-1

When I upgraded this morning, and attempted to logout then back in. 
gnome-panel continues to crash and will not start.  It appears to work
fine for a newly created local user.  I imagine that some applet is
causing the failure.

$ strace -o /tmp/panel.strace gnome-panel
 
** ERROR **: file egg-recent-item.c: line 303
(egg_recent_item_get_short_name): assertion failed: (uri != NULL)
aborting...

So is this the eggcups (provided by desktop-printing) applet that's
causing the failure?  I will attach my stack trace, and strace output
to this bug.
Comment 1 James Laska 2004-08-11 11:46:19 EDT
Created attachment 102609 [details]
panel.strace
Comment 2 James Laska 2004-08-11 11:46:36 EDT
Created attachment 102610 [details]
panel.debuginfo
Comment 3 James Laska 2004-08-11 11:53:57 EDT
I have resolved the issue by purging the $HOME/.gnome2 directory

Is this still an issue considering this is more of a gnome 2.7 upgrade
path?
Comment 4 James Laska 2004-08-11 11:56:20 EDT
Also discovered that when I add the main menu applet to the panel, I
get what appears to be the same crash
Comment 5 Mark McLoughlin 2004-08-11 12:05:44 EDT
If you can reproduce the crash, could you attach ~/.recently-used ?
Comment 7 James Laska 2004-08-11 12:29:19 EDT
I neglected to mention that removing $HOME/.recently-used has
circumvented the bug.
Comment 8 Leonard den Ottolander 2004-08-13 08:41:10 EDT
Why is this bug only available for Fedora Project Contributors? Who
are these? Not really sure what the use of making this bug somewhat
private is...
Comment 9 James Laska 2004-08-13 09:32:28 EDT
This was not intentional, fixed.
Comment 10 Thomas J. Baker 2004-08-13 10:02:30 EDT
Removing the .recently-used fixed it for me. I guess it would have
been better if I saved it though. Duh!
Comment 11 Luke Hutchison 2004-08-16 19:12:22 EDT
I have a similar problem -- I have entries in my .recently-used which
have mal-formed URIs in them, e.g.:

  <RecentItem>
    <URI>http://o-for-CS.pdf</URI>
    <Mime-Type>application/pdf</Mime-Type>
    <Timestamp>1089837322</Timestamp>
    <Groups>
    </Groups>
  </RecentItem>


This should have had the following for the URI line:

    <URI>file:///home/lhutchis/hunter-bio-for-CS.pdf</URI>

Other examples include:
 
    <URI>http://ger(1).pdf</URI>
    <URI>http://lides.ppt</URI>
    <URI>http://pm_R1b.svg</URI>
    <URI>http://re.zip</URI>
 
Some of these are old files, so I don't remember their full names, but
I know at least of two of them, again in my home directory or a
subdir: Slides.ppt and graphm_R1b.svg.

I think that somewhere, egg-recent-item is corrupting strings before
it adds them to .recently-used.

This is actually causing me to get locked out of my proxy server
frequently, because the Panel then tries to access these as domain
names when it updates its list of recently used files.
Comment 12 Mark McLoughlin 2004-08-17 03:29:32 EDT
Upstream bug:

  http://bugzilla.gnome.org/show_bug.cgi?id=150218

Luke's problem is different. James's crash was caused by 

  <RecentItem>
    <URI>x-nautilus-desktop:///home</URI>
    <Mime-Type>application/octet-stream</Mime-Type>
    <Timestamp>1092226462</Timestamp>
    <Groups>
    </Groups>
  </RecentItem>


We should have this fixed very soon
Comment 13 Mark McLoughlin 2004-08-30 06:58:07 EDT
There was a fix for this in 2.7.91.1
Comment 14 Eric Sanford 2005-12-26 19:22:57 EST
Hello,

I had the same problem when I tried to add a link to a webpage on the desktop. 
I fixed it by deleting the following entries from the .recently-used file.

--- .recently-used.old  2005-12-26 18:55:41.000000000 -0500
+++ .recently-used      2005-12-26 18:56:13.000000000 -0500
@@ -31,20 +31,6 @@
     </Groups>
   </RecentItem>
   <RecentItem>
-    <URI>http://www.spamcop.net/mcgi?action=loginform;returnurl=%2Fsc</URI>
-    <Mime-Type>text/html</Mime-Type>
-    <Timestamp>1135538013</Timestamp>
-    <Groups>
-    </Groups>
-  </RecentItem>
-  <RecentItem>
-    <URI>http://www.spamcop.net/sc</URI>
-    <Mime-Type>text/html</Mime-Type>
-    <Timestamp>1135537977</Timestamp>
-    <Groups>
-    </Groups>
-  </RecentItem>
-  <RecentItem>
     <URI>file:///usr/share/autoconf/autoconf/status.m4</URI>
     <Mime-Type>text/plain</Mime-Type>
     <Timestamp>1135537741</Timestamp>

Note You need to log in before you can comment on or make changes to this bug.