Bug 1296631 - visualization corrupted when scrolling
visualization corrupted when scrolling
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 12:13 EST by Cornelia Pfeffer
Modified: 2016-11-11 10:26 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-11 10:26:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
corrupted visualization after scrolling (348.71 KB, image/png)
2016-01-07 12:13 EST, Cornelia Pfeffer
no flags Details
when zoom = page width, the problem non occures (343.87 KB, image/png)
2016-01-07 12:14 EST, Cornelia Pfeffer
no flags Details

  None (edit)
Description Cornelia Pfeffer 2016-01-07 12:13:01 EST
Created attachment 1112522 [details]
corrupted visualization after scrolling

When I scroll a document up and down, the visualization of the text gets corrupted. Normally I have a zoom visualization, because I don't see too well. When I put visualization at "page width", the problem does not occur, only when the visualization is a bigger zoom.


Version:
LibreOffice 5


How reproducible:
Take a document with more than 1 page. Visualize it with a zoom that is wider than page width. Scroll quickly up and down


Additional info: 
when you make some other operation, like going on another desktop and turning back, the visualization is ok again. When you scroll again, it is again corrupted.

I attach a screenshot with corrupted visualization after scrolling and after that a screenshot with perfect visualization using page width
Comment 1 Cornelia Pfeffer 2016-01-07 12:14 EST
Created attachment 1112535 [details]
when zoom = page width, the problem non occures
Comment 2 Davide Repetto 2016-01-09 02:26:24 EST
The same thing happens here, with or without hardware acceleration and on both 32 and 64bit machines.

Relevant Version:
=================
libreoffice-5.0.4.2-3.fc23
Comment 3 Caolan McNamara 2016-01-27 10:21:33 EST
This is the only report like this wrt corruption on scrolling. so it doesn't appear to be a common problem. What desktop env are you using there ?
Comment 4 Cornelia Pfeffer 2016-01-27 10:41:54 EST
desktop env. MATE

obviously in family we have all the same, and it happens to all of us
Comment 5 Cornelia Pfeffer 2016-01-28 11:08:02 EST
today we found out that if you select in LibreOffice - Instruments - Options - Visualization "use OpenGL for all rendering" (sorry if it's a bit different in english but I have the italian version and I'm only trying to translate...), there is no corruption when scrolling
Comment 6 Caolan McNamara 2016-11-11 10:26:00 EST
can't reproduce it, so can't fix it unfortunately. I can only hope that an upgrade to e.g. f24 improves matters.

Note You need to log in before you can comment on or make changes to this bug.