Bug 1296697 - "Change several bugs at once" will erroneously reset the QA Contact field to its default
"Change several bugs at once" will erroneously reset the QA Contact field to ...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
4.4
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: Matt Tyson
tools-bugs
: Regression
: 1297909 1298602 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 17:20 EST by John Feeney
Modified: 2016-06-05 20:41 EDT (History)
8 users (show)

See Also:
Fixed In Version: 4.4.11046.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-24 23:45:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Feeney 2016-01-07 17:20:11 EST
Description of problem:

When using "Change several bugs at once", selecting one or more bzs to be changed, modifying the Subcomponent field while leaving the "QA Contact"
field alone (so it stays "do-not-change"), the QA Contact field will revert back to the default value.

Not sure if this is exclusive to the Subcomponent and QA Contact fields or if other field changes will effect QA Contact OR other fields will be reset to default in addition to QA Contact but I have been annoying my QE counterpart by making modifications to fields and I would like to stop being annoying.

Version-Release number of selected component (if applicable):
Bugzilla version 4.4.11045.3

How reproducible:
Seems to happen all the time.

Steps to Reproduce:
1.
2.
3.

Actual results:
"do-no-change" is not adhered.

Expected results:
A field that is "do-not-change" should remain unchanged.

Additional info:
Comment 1 Jeff Bastian 2016-01-07 17:43:36 EST
For an example, these 8 bugs were changed by "Change several bugs at once" yesterday when moving the state from NEW to ASSIGNED, and both the Assignee and QA Contact were reset to default values (which was not desired).

https://bugzilla.redhat.com/buglist.cgi?quicksearch=1266807%2C1266475%2C1266473%2C1266428%2C1266422%2C1266418%2C1266415%2C1266413&list_id=4406429
Comment 2 Jason McDonald 2016-01-07 19:36:43 EST
I discussed this bug with John Shortt yesterday.  There has been a regression at some point where the "Reset Assignee to Default" checkbox is now checked by default instead of clear.  (The same is true for hte QA contact and Docs Contact checkboxes.)

Every field on the bulk-change form should default to "-do-not-change-", so the checkboxes should be clear by default.
Comment 3 Jeff Bastian 2016-01-08 08:40:34 EST
We first noticed this bug in mid-December [0], if that helps to narrow down when the regression was introduced, possibly with the upgrade to 4.4.10045.3 on Dec 15 [1].

[0] http://post-office.corp.redhat.com/archives/bugzilla-list/2015-December/msg00016.html
[1] http://post-office.corp.redhat.com/archives/bugzilla-development-list/2015-December/msg00003.html
Comment 4 John Feeney 2016-01-11 17:19:20 EST
Someone else just trundled into this with 15-20 bugzillas. Took out the Assigned To field in addition to the QA field. Very time consuming to put back the correct values. Please fix as soon as possible. Thanks.
Comment 5 Jeff Bastian 2016-01-11 17:33:24 EST
Another batch of 34 kernel-aarch64 bugs just had their Assignee and QA Contacts reset to default values.  Please fix this bug soon since it's not easy to undo these mass updates.
Comment 6 Matt Tyson 2016-01-12 00:11:59 EST
Yeah, that's really bad.  Sorry about that.
Comment 7 Matt Tyson 2016-01-12 01:02:14 EST
I'm organizing a hotfix for this issue.
Comment 8 Rony Gong 2016-01-12 20:57:13 EST
Tested on 
Rdu environment with version(4.4.11045-4, DB: psql)
Result: Pass
Steps:
1.Search a bug list, then click link 'Change Several Bugs at Once', then select some bugs in the new page
==>"Reset Assignee to Default" checkbox is now unchecked by default
==>"Reset QA to Default" checkbox is now unchecked by default
==>"Reset Docs Contact to Default" checkbox is now unchecked by default
2.Select new product, component and subcomponent 
==>"Reset Assignee to Default" checkbox is still unchecked by default
==>"Reset QA to Default" checkbox is still unchecked by default
==>"Reset Docs Contact to Default" checkbox is still unchecked by default
3. Commit
==>all selected bug's role not changed, same as before.
4. Also check the output of check that 3 checkbox manually
==>all selected bug's role changed to the component/subcomonent's default setting.
Comment 10 John Shortt 2016-01-12 21:43:30 EST
*** Bug 1297909 has been marked as a duplicate of this bug. ***
Comment 11 Muhammad Tahir 2016-01-14 17:54:21 EST
*** Bug 1298602 has been marked as a duplicate of this bug. ***
Comment 12 Matt Tyson 2016-01-24 23:45:56 EST
This change is now live. If there are any issues, do not reopen this bug. Instead, you should create a new bug and reference this bug.

Note You need to log in before you can comment on or make changes to this bug.