Bug 1296699 - Eclipse 4.5 debugger unbearably slow under GTK3
Eclipse 4.5 debugger unbearably slow under GTK3
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 17:36 EST by Alex Wood
Modified: 2016-01-11 11:25 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 11:25:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Thread dump of Eclipse while attempting to run debugger. (22.29 KB, text/plain)
2016-01-07 17:36 EST, Alex Wood
no flags Details

  None (edit)
Description Alex Wood 2016-01-07 17:36:37 EST
Created attachment 1112624 [details]
Thread dump of Eclipse while attempting to run debugger.

Description of problem:
Eclipse 4.5 (Mars) runs unbearably slowly under GTK3.  The problem manifests most significantly for me in the debugger, although I do notice it to some extant when importing projects.

Version-Release number of selected component (if applicable): 
% rpm -q eclipse-platform gtk3
eclipse-platform-4.5.1-6.fc23.x86_64
gtk3-3.18.6-1.fc23.x86_64

How reproducible: Unsure.  It seems to be working fine on a laptop I have, but on my desktop, performance is consistently poor.

Steps to Reproduce:
1. Install eclipse-platform and eclipse-jdt
2. Import a project, create a breakpoint on a class, and then run something that would hit that breakpoint.  E.g. a unit test.

Actual results:  The debugger never even connects to the JVM or if it does, it's so sluggish as to be unusable.

Expected results: Working debugger.

Additional info:  If I use the same workspace, same ~/.eclipse, and just run `eclipse eclipse --launcher.GTK_version 2` everything works and is quite fast.  I've taken a thread dump (attached) and when using the VisualVM profiler, I see that 33% of the time is spent in org.eclipse.swt.internal.gtk.OS._gdk_window_get_origin[native] with an additional 28% in org.eclipse.swt.internal.gtk.OS._gdk_cairo_region_create_from_surface[native]

Please let me know any additional information you might need and I will be happy to provide it.
Comment 1 Alexander Kurtakov 2016-01-08 01:08:54 EST
Please try https://bodhi.fedoraproject.org/updates/FEDORA-2016-3c119d77c0 it has a fix for a bug that I think this one is duplicate of.
Comment 2 Alex Wood 2016-01-11 11:15:38 EST
The fix looks like it's working after a quick smoke test.  Thanks!  This bug can be closed I believe.
Comment 3 Alexander Kurtakov 2016-01-11 11:25:21 EST
Marking as fixed.

Note You need to log in before you can comment on or make changes to this bug.