Bug 1296711 - dnf distro-sync downgrades libpng packet, which seems vanished from repos since then
dnf distro-sync downgrades libpng packet, which seems vanished from repos sin...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On: 1292914
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-07 18:55 EST by Hannes Frederic Sowa
Modified: 2016-01-09 16:56 EST (History)
8 users (show)

See Also:
Fixed In Version: libpng-1.6.19-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-09 16:56:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hannes Frederic Sowa 2016-01-07 18:55:43 EST
I ran a dnf distro-sync and accidentally accepted the following transaction which downgraded libpng:

Transaction performed with:
    Installed     dnf-1.1.5-1.fc23.noarch        @updates
    Installed     rpm-4.13.0-0.rc1.7.fc23.x86_64 @updates
Packages Altered:
    Downgrade  libpng-2:1.6.17-3.fc23.i686   @updates
    Downgrade  libpng-2:1.6.17-3.fc23.x86_64 @updates
    Downgraded        2:1.6.19-1.fc23.i686   @updates
    Downgraded        2:1.6.19-1.fc23.x86_64 @updates

I actually thought this isn't a big problem, a dnf update should update it again. But this didn't happen. Actually I found out that this update happend two months ago and since then vanished from the mirrors in the update repository? Now I am a bit confused. :) Is this a bug?

Sorry for filing it in the dnf category, but couldn't find a better place.
Comment 2 Hannes Frederic Sowa 2016-01-07 18:59:32 EST
Package seems definitely to exist in bodhi:
https://bodhi.fedoraproject.org/updates/FEDORA-2015-9199a1bfe1
Comment 4 Andre Robatino 2016-01-08 06:18:08 EST
(In reply to Petr Hracek from comment #3)
> Fixed by commit
> http://pkgs.fedoraproject.org/cgit/rpms/libpng.git/commit/
> ?h=f23&id=1703ede809b0431d1fde239ab3135b974b4eec9c

I'm pretty sure that's just a bodhi bug ( https://bugzilla.redhat.com/show_bug.cgi?id=1292914 ) and dgilmore should be able to fix it and get 1.6.19-1 back where it belongs. He hasn't responded to my message https://bugzilla.redhat.com/show_bug.cgi?id=1292914#c4 yet though. He did fix it when qemu was downgraded.
Comment 5 Fedora Update System 2016-01-08 06:21:47 EST
libpng-1.6.19-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0794f92d85
Comment 6 Hannes Frederic Sowa 2016-01-08 08:37:25 EST
(In reply to Andre Robatino from comment #4)
> (In reply to Petr Hracek from comment #3)
> > Fixed by commit
> > http://pkgs.fedoraproject.org/cgit/rpms/libpng.git/commit/
> > ?h=f23&id=1703ede809b0431d1fde239ab3135b974b4eec9c
> 
> I'm pretty sure that's just a bodhi bug (
> https://bugzilla.redhat.com/show_bug.cgi?id=1292914 ) and dgilmore should be
> able to fix it and get 1.6.19-1 back where it belongs. He hasn't responded
> to my message https://bugzilla.redhat.com/show_bug.cgi?id=1292914#c4 yet
> though. He did fix it when qemu was downgraded.

Yes, it is. I already added BZ#1292914 as a dependency. It feels scary that bodhi loses updates, especially critical things like qemu or libpng.

Thanks Petr for bumping libpng!
Comment 7 Fedora Update System 2016-01-08 23:26:53 EST
libpng-1.6.19-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0794f92d85
Comment 8 Fedora Update System 2016-01-09 16:56:49 EST
libpng-1.6.19-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.