Bug 1296917 - Tier: Need to overwrite the /var/run/gluster/<vol>/<demotequey> on each cycle [NEEDINFO]
Tier: Need to overwrite the /var/run/gluster/<vol>/<demotequey> on each cycle
Status: CLOSED WORKSFORME
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Lambright
nchilaka
tier-migration
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-08 07:41 EST by RajeshReddy
Modified: 2016-09-17 11:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-15 06:28:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
nbalacha: needinfo? (rmekala)


Attachments (Terms of Use)

  None (edit)
Description RajeshReddy 2016-01-08 07:41:08 EST
Description of problem:
=========
Tier: Need to overwrite the /var/run/gluster/<vol>/<demotequey> on each cycle 

Version-Release number of selected component (if applicable):
============
glusterfs-server-3.7.5-15


How reproducible:


Steps to Reproduce:
===========
1. After querying the DB placing all eligible files (promoted/demoted)   /var/run/gluster/<vol>/<demotequey>, we are processing all the entries in the file and then querying the DB, though multiple cycles passed in between 
2.
3.

Actual results:


Expected results:
=========
On each cycle need to query the DB and overwrite the /var/run/gluster/<vol>/<demotequey> and should not process the existing since the entries are stale 


Additional info:
Comment 3 RajeshReddy 2016-01-11 01:12:56 EST
I created lot of files and deleted them but tierd keep on trying to demote files which were deleted and able to see lot of error messages in the log saying lookup of given file is failed and seeing the same messages on the log after couple of hours too 

so i am thinking we are not overwriting the /var/run/gluster/<vol>/<demotequey> after each cycle
Comment 4 Nithya Balachandran 2016-01-11 01:19:59 EST
The query files are generated from the database. If the database has not been modified, the query will generate the same results each time and you will end up with the same entries in the query file.

You can verify whether the files is being overwritten by deleting the .err file. The next failed cycle should rename the new query file to .err file. You can also delete the query file and see if it is being recreated in the next cycle(It should).

If the above is true, this is not a bug.
Comment 5 RajeshReddy 2016-01-14 06:29:44 EST
After deleting the .err file it is not getting created after next cycle
Comment 6 Nithya Balachandran 2016-01-15 10:30:03 EST
Did the promotions/demotions fail? The .err file is created only when there is a failure.

The .err file deletion test was suggested specifically for the setup on which demotion failures were reported. If the migration is successful, a better test would be to check the size of the file between cycles.
Comment 8 Nithya Balachandran 2016-07-15 06:28:32 EDT
This is already done as part of tiering. Closing this as WorkForMe.

Note You need to log in before you can comment on or make changes to this bug.