Bug 1296954 - autodownloader binary placed in /usr/share/
autodownloader binary placed in /usr/share/
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: autodownloader (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-08 09:27 EST by Pavel Alexeev
Modified: 2016-01-18 07:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-18 07:48:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Alexeev 2016-01-08 09:27:27 EST
Description of problem:

It called /usr/share/autodl/AutoDL.py and intended to be used for run such by documentation.

According to FHS [1] common binaries must be placed under /usr/bin

I also suggest place under /usr/bin without .py suffix. May be symlink or wrapper.


[1] https://en.wikipedia.org/wiki/Filesystem_Hierarchy_Standard

Version-Release number of selected component (if applicable):
$ rpm -q autodownloader 
autodownloader-0.3.0-10.fc23.noarch

How reproducible:
Always.
Comment 1 Hans de Goede 2016-01-08 14:36:00 EST
autodownloader is only intended to be called from (shell) scripts, not by users directly (it will not work without a .autodl config file, so it really does not belong in $PATH.
Comment 2 Pavel Alexeev 2016-01-08 17:22:14 EST
Many binaries can't be used correctly without proper arguments (rm f.e.). What it changes?

Why you do not want place it under traditional binary place?

Note You need to log in before you can comment on or make changes to this bug.