Bug 1297052 - openstack-puppet-modules build is out of date and wrong branch in Delorean repos
openstack-puppet-modules build is out of date and wrong branch in Delorean repos
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-puppet-modules (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Liberty
Assigned To: Alan Pevec
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-08 16:37 EST by David Moreau Simard
Modified: 2016-04-18 03:14 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-8.0.0a0-6.gfa42243.el7.centos openstack-puppet-modules-7.0.4-9.gc1a6222.el7.centos
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 18:59:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Moreau Simard 2016-01-08 16:37:09 EST
When doing packstack --allinone with current mitaka delorean, installation fails to complete with an error from Cinder:

21:02:26 ERROR : Error appeared during Puppet run: 172.19.2.49_cinder.pp
21:02:26 Error: Unsupported backend configured at /var/tmp/packstack/491ab150779549a08058bf1b8f7693e6/modules/cinder/manifests/db.pp:75 on node pksk-rdo-wvxjb-rhos-ci-12-controller

When looking at the manifest, we notice that it tries to configure the mysql database with the following string:
database_connection => "mysql+pymysql://cinder:${cinder_rab_cfg_cinder_db_pw}@${cinder_rab_cfg_mariadb_host}/cinder",

The cinder module provided by OPM does not have pymysql support merged. It seems an update to OPM in delorean repositories would fix this since this support has been upstream for a while.

Complete logs: https://ci.centos.org/artifacts/rdo/jenkins-dmsimard-packstack-aio+tester-poc-12/
Comment 1 Alan Pevec 2016-01-12 06:34:06 EST
OPM spec and OPM build script in Delorean are now fixed to build OPM RPM from the appropriate branch and use git tags for the version.
Comment 3 Alan Pevec 2016-01-13 06:55:48 EST
New OPM was built last night in both mitaka and liberty deloreans.

Note You need to log in before you can comment on or make changes to this bug.