This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1297088 - dnf install of group "Engineering and Scientific" produces conflict messages
dnf install of group "Engineering and Scientific" produces conflict messages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: TOPCOM (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-08 19:32 EST by George R. Goffe
Modified: 2016-01-21 21:22 EST (History)
3 users (show)

See Also:
Fixed In Version: TOPCOM-0.17.6-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 22:05:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George R. Goffe 2016-01-08 19:32:50 EST
Description of problem:

dnf install produces conflicts message: Error: Transaction check error:
  file /usr/bin/cube from install of TOPCOM-0.17.6-1.fc24.x86_64 conflicts with file from package cube-4.3.3-1.fc24.x86_64


Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1.dnf -y group install with-optional --best --allowerasing 'Electronic Lab'
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 George R. Goffe 2016-01-08 19:40:05 EST
Steps to reproduce is incorrect. group should be: "Engineering and Scientific"

dnf -y group install with-optional --best --allowerasing "Engineering and Scientific"
Comment 2 Orion Poplawski 2016-01-08 21:04:02 EST
Bringing in the TOPCOM maintainers....

cube is a pretty lousy, generic name.  Both probably should be renamed.
Comment 3 Jerry James 2016-01-09 12:17:35 EST
Yes, TOPCOM has several binary names that are really generic: cross, cube, cyclic, lattice.  I've wondered many times whether I shouldn't hide TOPCOM behind environment-modules, but that makes using latte-integrale and polymake problematic, since they expect to find the TOPCOM binaries in PATH.

I could try to figure out the set of TOPCOM programs that are actually used by latte-integrale and polymake, leave those in %{_bindir}, and hide the rest with environment-modules.  The downside is that if newer versions of those programs use more TOPCOM binaries, they will break at runtime unless someone happens to notice and do something about it before they are updated.

Right now, latte-integrale uses only points2triangs and points2placingtriang.  Polymake uses only points2chiro.

Maybe I should just rename the generically named binaries to TOPCOM-cross, TOPCOM-cube, etc. and deal with any future breakage if it arises.

Thoughts?
Comment 4 George R. Goffe 2016-01-09 14:37:26 EST
Jerry,

I think I'd vote for your last idea or maybe have a wrapper to invoke? TOPCOM cube <args> for example?

Regards,

George...
Comment 5 Orion Poplawski 2016-01-11 16:17:54 EST
The wrapper is not a bad idea - that's the way GMT has gone as well.  Thanks for taking this on - I do think it will be easier to change TOPCOM than cube, but that's perhaps a biased view too :).
Comment 6 Fedora Update System 2016-01-12 23:12:58 EST
TOPCOM-0.17.6-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4fbbaaf708
Comment 7 Fedora Update System 2016-01-14 06:26:05 EST
TOPCOM-0.17.6-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4fbbaaf708
Comment 8 Dave Love 2016-01-14 06:42:43 EST
(In reply to Orion Poplawski from comment #2)
> Bringing in the TOPCOM maintainers....
> 
> cube is a pretty lousy, generic name.  Both probably should be renamed.

If that happens, it will require a change in scalasca, which I think is the
only thing in Fedora currently invoking it.
Comment 9 Jerry James 2016-01-20 22:05:35 EST
(In reply to Dave Love from comment #8)
> If that happens, it will require a change in scalasca, which I think is the
> only thing in Fedora currently invoking it.

No worries.  I have changed TOPCOM, so the cube package can remain unchanged ... at least until something else comes along that wants to be called cube. :-)
Comment 10 Fedora Update System 2016-01-21 21:22:36 EST
TOPCOM-0.17.6-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.