Bug 129713 - XMMS i18n in Bulgarian Locale - menus and text are populated as "squares"
XMMS i18n in Bulgarian Locale - menus and text are populated as "squares"
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xmms (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-11 20:18 EDT by Nikolay
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 15:16:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikolay 2004-08-11 20:18:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686) Opera 
7.50  [bg]

Description of problem:
When you open the XMMS and your default locale is Bulgarian the Menu 
items and the text is in incorrect code (not Bulgarian characters but 
squares). Obviously the either encoding or font is incorrect. I 
experience the same issue with the Hardware browser. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start xmms
2.right click opens menu list
3.see the menu items text are in squares
    

Actual Results:  see the menu items text is in squares

Expected Results:  text should be in Bulgarian

Additional info:

I saw that in Hardware browser as well and in Russian Locale too.
Comment 1 Nikolay 2004-08-13 13:32:02 EDT
command locale output:

LANG=bg_BG.UTF-8
LC_CTYPE="bg_BG.UTF-8"
LC_NUMERIC="bg_BG.UTF-8"
LC_TIME="bg_BG.UTF-8"
LC_COLLATE="bg_BG.UTF-8"
LC_MONETARY="bg_BG.UTF-8"
LC_MESSAGES="bg_BG.UTF-8"
LC_PAPER="bg_BG.UTF-8"
LC_NAME="bg_BG.UTF-8"
LC_ADDRESS="bg_BG.UTF-8"
LC_TELEPHONE="bg_BG.UTF-8"
LC_MEASUREMENT="bg_BG.UTF-8"
LC_IDENTIFICATION="bg_BG.UTF-8"
LC_ALL=
Comment 2 Nikolay 2004-09-04 10:06:45 EDT
it is same problem like in bug#109158
Comment 3 Nikolay 2004-09-18 14:57:30 EDT
Description of problem:
In many Gtk-1.2 applications (Gimp, xmms etc), I see squares instead
Russian letters. This because, XFree has incorrect fonts, without
Russian glyphs. This old problem begin from Red Hat 8.0. It is
possible to fix it, if make thease steps:
1. Get right fonts from 
ftp://ftp.asplinux.ru/pub/fonts/XFree86-iso10646cyr-fonts.tar.bz2
2. There are .bdf files in this archive. I make pcf.gz from it via
bdftopcf utility
3. Put .pcf.gz fonts into /usr/X11R6/lib/X11/fonts/75dpi directory
with replace old fonts.
4. Run mkfontdir in this directory
5. Restart X Font Server (xfs)
After thease steps, all is OK.

Version-Release number of selected component (if applicable):

Note You need to log in before you can comment on or make changes to this bug.