Bug 1297177 - nodejs-mysql should depend on nodejs-readable-stream
nodejs-mysql should depend on nodejs-readable-stream
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nodejs-mysql (Show other bugs)
23
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Troy Dawson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-10 04:27 EST by Robin Rainton
Modified: 2016-01-20 16:54 EST (History)
2 users (show)

See Also:
Fixed In Version: nodejs-mysql-2.6.2-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 16:54:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Rainton 2016-01-10 04:27:52 EST
Description of problem:

The nodejs-mysql package should depend on nodejs-readable-stream. Without this certain nodejs-mysql code cannot function and cause run-time errors.

Version-Release number of selected component (if applicable):

nodejs-mysql.noarch 2.6.2-2.fc23

How reproducible:

100%

Steps to Reproduce:
1. dnf install nodejs-mysql
2. Execute some node MySQL code. Eg. something like the first example here: http://www.codediesel.com/nodejs/querying-mysql-with-node-js/

Actual results:

This error occurs:

Error: Cannot find module 'readable-stream'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/usr/lib/node_modules/mysql/lib/protocol/sequences/Query.js:7:20)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)

Expected results:

Query should work.

Additional info:

This can be solved by:

dnf install nodejs-readable-stream

This package just needs to be made a dependency.
Comment 1 Troy Dawson 2016-01-12 09:41:44 EST
Sorry about that.
Looks like I didn't review the dependencies the past couple of updates.
Working on it.
Comment 2 Fedora Update System 2016-01-12 15:49:42 EST
nodejs-mysql-2.6.2-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9365dc1245
Comment 3 Fedora Update System 2016-01-13 02:53:19 EST
nodejs-mysql-2.6.2-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9365dc1245
Comment 4 Fedora Update System 2016-01-20 16:54:13 EST
nodejs-mysql-2.6.2-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.