Bug 1297194 - phatch doesn't start
phatch doesn't start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: phatch (Show other bugs)
24
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Jaromír Cápík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-10 07:14 EST by Nuno Dias
Modified: 2016-08-29 17:21 EDT (History)
4 users (show)

See Also:
Fixed In Version: phatch-0.2.7-26.fc25 phatch-0.2.7-26.fc24 phatch-0.2.7-26.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-29 11:37:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to solve the problem (1.23 KB, patch)
2016-01-10 07:14 EST, Nuno Dias
no flags Details | Diff
Patch the correct one (1.15 KB, patch)
2016-01-10 07:24 EST, Nuno Dias
no flags Details | Diff
phatch-0.2.7-fromstring-tostring-deprecated.patch (1.35 KB, patch)
2016-08-21 05:33 EDT, Jaromír Cápík
no flags Details | Diff

  None (edit)
Description Nuno Dias 2016-01-10 07:14:00 EST
Created attachment 1113300 [details]
Patch to solve the problem

Description of problem:
phatch doesn't start, I attached the patch to solve the problem

Version-Release number of selected component (if applicable):
phatch-cli-0.2.7-22.fc23.noarch

How reproducible:


Steps to Reproduce:
1.start phatch
2.
3.

Actual results:


Expected results:


Additional info:
11:55:36: Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1008,wx containers,compatible with 2.8).
/usr/lib/python2.7/site-packages/phatch/lib/notify.py:24: PyGIWarning: Notify was imported without specifying a version first. Use gi.require_version('Notify', '0.7') before import to ensure that the right version gets loaded.
  import gi.repository.Notify as pynotify
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/_core.py", line 16762, in <lambda>
    lambda event: event.callable(*event.args, **event.kw) )
  File "/usr/lib/python2.7/site-packages/phatch/pyWx/gui.py", line 1218, in show_frame
    frame = Frame(self.filename, None, -1, ct.TITLE)
  File "/usr/lib/python2.7/site-packages/phatch/pyWx/gui.py", line 327, in __init__
    frame.Frame.__init__(self, *args, **keyw)
  File "/usr/lib/python2.7/site-packages/phatch/pyWx/wxGlade/frame.py", line 141, in __init__
    self.tree = Tree(self, -1, style=wx.TR_HAS_BUTTONS|wx.TR_NO_LINES|wx.TR_FULL_ROW_HIGHLIGHT|wx.TR_HIDE_ROOT|wx.TR_DEFAULT_STYLE|wx.SUNKEN_BORDER)
  File "/usr/lib/python2.7/site-packages/phatch/pyWx/wxGlade/frame.py", line 26, in __init__
    set_dirty   = parent.set_dirty,
  File "/usr/lib/python2.7/site-packages/phatch/lib/pyWx/treeEdit.py", line 96, in __init__
    self.CreateImageList(icon_size)
  File "/usr/lib/python2.7/site-packages/phatch/lib/pyWx/treeEdit.py", line 111, in CreateImageList
    self._AddFormToImageList(form, icon_size, icon_disabled)
  File "/usr/lib/python2.7/site-packages/phatch/lib/pyWx/treeEdit.py", line 120, in _AddFormToImageList
    wx_image = pil_wxImage(wxImage_pil(wx_image).resize(icon_size,\
  File "/usr/lib/python2.7/site-packages/phatch/lib/pyWx/wxPil.py", line 46, in wxImage_pil
    image.fromstring(wx_image.GetData())
  File "/usr/lib64/python2.7/site-packages/PIL/Image.py", line 737, in fromstring
    "Please call frombytes() instead.")
Exception: fromstring() has been removed. Please call frombytes() instead.
Comment 1 Nuno Dias 2016-01-10 07:24 EST
Created attachment 1113308 [details]
Patch the correct one

Sorry the previous patch included things from the patch in the rpm, I uploaded a new one
Comment 2 David GEIGER 2016-06-27 08:17:50 EDT
Hi,

We have encountered the same issue on Mageia and I confirm that the proposed patch fixes properly this issue.


For reference:
http://svnweb.mageia.org/packages/cauldron/phatch/current/SOURCES/phatch-deprecated-fromstring-and-tostring-call.patch?view=markup&pathrev=1037737
Comment 3 Nuno Dias 2016-08-07 08:05:01 EDT
It's possible someone update this package with the patch? two releases of Fedora and the bug is still there, there are no reason to ship a software that doesn't run for so long when there are a patch and is trivial to apply :(

Thanks
Comment 5 Nuno Dias 2016-08-13 06:35:18 EDT
 Dear Jaromír Cápík,

 This is the last attempt to contact you, I already sent you a mail without success, if this ticket is not updated, I will start the procedure "What to do if a maintainer is absent".

Thanks
Comment 6 Jaromír Cápík 2016-08-20 02:29:03 EDT
Hello Nuno.

The patch looks ok.
Comment 7 Jaromír Cápík 2016-08-20 06:29:30 EDT
I'll apply the patch this evening. Sorry for the delay.
Comment 8 Jaromír Cápík 2016-08-21 04:27:07 EDT
In my case the patch doesn't work like expected. Going to update to the latest versions of components.
Comment 9 Jaromír Cápík 2016-08-21 05:22:36 EDT
Well. It looks like your patch modifies just a backup of the wxPil.py source, called wxPil.py.orig. What needs to be modified is the wxPil.py source.
Comment 10 Jaromír Cápík 2016-08-21 05:33 EDT
Created attachment 1192561 [details]
phatch-0.2.7-fromstring-tostring-deprecated.patch

This one would work.
Comment 11 Fedora Update System 2016-08-21 06:11:33 EDT
phatch-0.2.7-26.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7347e3f695
Comment 12 Fedora Update System 2016-08-21 06:11:45 EDT
phatch-0.2.7-26.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7b0204f056
Comment 13 Fedora Update System 2016-08-21 06:11:52 EDT
phatch-0.2.7-26.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-71d885a072
Comment 14 Jaromír Cápík 2016-08-21 06:14:18 EDT
*** Bug 1327151 has been marked as a duplicate of this bug. ***
Comment 15 Jaromír Cápík 2016-08-21 06:21:18 EDT
Koji build tested and works.

Hope you're doing well. I'm not.
Comment 16 Fedora Update System 2016-08-21 15:52:10 EDT
phatch-0.2.7-26.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7347e3f695
Comment 17 Fedora Update System 2016-08-21 16:51:27 EDT
phatch-0.2.7-26.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-71d885a072
Comment 18 Fedora Update System 2016-08-21 16:52:49 EDT
phatch-0.2.7-26.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7b0204f056
Comment 19 Fedora Update System 2016-08-29 11:37:39 EDT
phatch-0.2.7-26.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2016-08-29 14:53:21 EDT
phatch-0.2.7-26.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2016-08-29 17:21:27 EDT
phatch-0.2.7-26.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.