Bug 1297206 - Rebuild needed for new FPC 3.0 in rawhide
Summary: Rebuild needed for new FPC 3.0 in rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lazarus
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Joost van der Sluis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-10 15:13 UTC by Mattia Verga
Modified: 2016-01-12 21:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-12 21:04:19 UTC


Attachments (Terms of Use)

Description Mattia Verga 2016-01-10 15:13:47 UTC
Please rebuild lazarus on the new FPC 3.0 in rawhide.

At the moment projects requiring lazarus are failing to build.

Thanks.
Mattia

Comment 1 Joost van der Sluis 2016-01-12 16:11:31 UTC
Rebuild of fpc will not work. Lazarus needs an update to 1.6-rc1. I'm working on that.

Comment 2 Mattia Verga 2016-01-12 19:19:15 UTC
Can you also set the "ExcludeArch: ppc64le" so that lazarus can build at least on ppc64?

Comment 3 Joost van der Sluis 2016-01-12 21:04:19 UTC
Aren't you mixing bugs here?

Fpc finished bootstrapping on ARM, so now Lazarus is updated to 1.6-rc1. So I'll close this bug.

I'll see if I can get fpc to work on ppc64 again. (It did in the past, but that target got removed from Fedora) But that's another bug.


Note You need to log in before you can comment on or make changes to this bug.