Bug 1297219 - virt-manager not starting
virt-manager not starting
Status: CLOSED DUPLICATE of bug 1236312
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-10 14:27 EST by Mebus
Modified: 2016-06-17 08:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-10 14:53:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mebus 2016-01-10 14:27:50 EST
Description of problem:

virt-manager does not start, but shows this output on the command line:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virt-manager", line 34, in <module>
    from virtinst import util as util
  File "/usr/share/virt-manager/virtinst/__init__.py", line 87, in <module>
    from virtinst.distroinstaller import DistroInstaller
  File "/usr/share/virt-manager/virtinst/distroinstaller.py", line 26, in <module>
    from . import urlfetcher
  File "/usr/share/virt-manager/virtinst/urlfetcher.py", line 27, in <module>
    import requests
  File "/usr/lib/python2.7/site-packages/requests/__init__.py", line 58, in <module>
    from . import utils
ImportError: cannot import name utils


Version-Release number of selected component (if applicable):

virt-manager-1.3.2-1.fc23.noarch
Comment 1 Cole Robinson 2016-01-10 14:31:49 EST
Thanks for the report. What's the output of these commands?

rpm -q python-requests
python -c 'import requests; print requests'
Comment 2 Mebus 2016-01-10 14:40:16 EST
Here is the output:

mebus@box ~ (git)-[home] % rpm -q python-requests
package python-requests is not installed
1 mebus@box ~ (git)-[home] % python -c 'import requests; print requests'                                                                                                                                                                 :(
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/requests/__init__.py", line 58, in <module>
    from . import utils
ImportError: cannot import name utils
1 mebus@box ~ (git)-[home] %     

Mebus
Comment 3 Cole Robinson 2016-01-10 14:41:48 EST
Hmm. Looks like the virt-manager RPM is missing a dep on python-requests, which you seemed to have manually installed already but the install is busted!

Does 'dnf install python-requests' fix virt-manager for you?
Comment 4 Cole Robinson 2016-01-10 14:43:15 EST
Err, virt-manager does actually have a dep on python-requests, so your RPM deps must have gotten out of whack somehow
Comment 5 Mebus 2016-01-10 14:50:48 EST
I cannot install it, see here:


1 mebus@box ~ (git)-[home] % sudo dnf install python-requests   

[...]   

Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Installing  : python-requests-2.9.1-1.fc23.noarch                                                                                                                                                                                      1/1 
Error unpacking rpm package python-requests-2.9.1-1.fc23.noarch
Error unpacking rpm package python-requests-2.9.1-1.fc23.noarch
error: unpacking of archive failed on file /usr/lib/python2.7/site-packages/requests/packages/chardet: cpio: rename
python-requests-2.9.1-1.fc23.noarch was supposed to be installed but is not!
  Verifying   : python-requests-2.9.1-1.fc23.noarch                                                                                                                                                                                      1/1 

Failed:
  python-requests.noarch 2.9.1-1.fc23
Comment 6 Cole Robinson 2016-01-10 14:53:26 EST
Looks like something related to this:

https://bugzilla.redhat.com/show_bug.cgi?id=1236312

I'd suggest following the steps listed in that bug

*** This bug has been marked as a duplicate of bug 1236312 ***
Comment 7 Jamie Duncan 2016-06-17 08:46:58 EDT
for the next person who finds this after a Fedora 23 update.

http://stackoverflow.com/questions/23378970/python-requests-importerror-no-module-named-util worked for me, not the py-enum bug.

Note You need to log in before you can comment on or make changes to this bug.