Bug 1297220 - Download links fail.
Download links fail.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-10 14:38 EST by Philip Heuer
Modified: 2016-01-25 08:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-25 08:14:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error message (19.75 KB, image/png)
2016-01-11 06:48 EST, Philip Heuer
no flags Details
console output (295.45 KB, image/png)
2016-01-11 06:52 EST, Philip Heuer
no flags Details
expected result (23.26 KB, image/png)
2016-01-11 06:58 EST, Philip Heuer
no flags Details
SSL Certificate (47.13 KB, image/png)
2016-01-11 07:49 EST, Philip Heuer
no flags Details
Fedora Firefox about:support (3.30 KB, text/plain)
2016-01-12 21:59 EST, Philip Heuer
no flags Details
Mozilla Firefox about:support (3.33 KB, text/plain)
2016-01-12 22:00 EST, Philip Heuer
no flags Details

  None (edit)
Description Philip Heuer 2016-01-10 14:38:34 EST
Description of problem:
When a download link is clicked, the downloads list shows that it failed.

Version-Release number of selected component (if applicable):
43.0.3-4

How reproducible:
Always

Steps to Reproduce:
1. Go to the Mozilla.org Firefox download page (i.e. download a fresh copy).
2. Click a download link.

Actual results:
Download fails.

Expected results:
Download should start. If configured, a dialog box for selecting the download location should appear.

Additional info:
The Firefox 43.0.4 downloaded from Mozilla works as expected. firefox-43.0.3-4.fc23.x86_64 fails in safe mode and regular mode. Patches 204, 215, 219, 220, 221, 222, 300, 500, and 501 do not appear to trigger the issue.
Comment 1 Martin Stransky 2016-01-11 03:44:38 EST
do you have any message in browser console? (tools -> web developer -> browser console). Also do you see any other error message? Is any message in download manager?
Comment 2 Philip Heuer 2016-01-11 06:48 EST
Created attachment 1113597 [details]
Error message
Comment 3 Philip Heuer 2016-01-11 06:52 EST
Created attachment 1113598 [details]
console output

The browser console displays a signature recommendation and no error messages regarding the download. The displayed warnings occur after clicking a download link.
Comment 4 Philip Heuer 2016-01-11 06:58 EST
Created attachment 1113599 [details]
expected result

This dialog was produced by the Firefox downloaded from Mozilla. The console output was the same as the Fedora build.
Comment 5 Martin Stransky 2016-01-11 07:03:30 EST
Can you please look at site information (right mouse button click -> view page info) choose "Security" tab and see the certificate? My Firefox build uses SHA2 on that page.

And yes, mozilla has enabled sha1 certificates because of WinXP users.
Comment 6 Philip Heuer 2016-01-11 07:49 EST
Created attachment 1113608 [details]
SSL Certificate
Comment 7 Martin Stransky 2016-01-12 15:50:07 EST
The certificate looks correct. I also have this one for mozilla.org downloads. I wonder why the download fails here...
Comment 8 Martin Stransky 2016-01-12 15:54:26 EST
Can you please attach content of about:support page? Use "Copy text to clipboard" way. Thanks.
Comment 9 Martin Stransky 2016-01-12 15:55:33 EST
btw. do you see that on any other site or just mozilla.org?
Comment 10 Philip Heuer 2016-01-12 21:59 EST
Created attachment 1114270 [details]
Fedora Firefox about:support
Comment 11 Philip Heuer 2016-01-12 22:00 EST
Created attachment 1114271 [details]
Mozilla Firefox about:support
Comment 12 Philip Heuer 2016-01-12 22:09:08 EST
(In reply to Martin Stransky from comment #9)
> btw. do you see that on any other site or just mozilla.org?

I also see this behavior on koji.fedoraproject.org. It seems to be independent of the domain.
Comment 13 Martin Stransky 2016-01-13 03:07:08 EST
Hm I don't see anything wrong here. Do you see anything related in /var/log/messages? Also, can you try to "browser.download.useDownloadDir" to true?
Comment 14 Martin Stransky 2016-01-13 03:08:09 EST
That may be also a problem with your temporary dir (/tmp or /var/tmp). Do you have anything in dmesg?
Comment 15 Philip Heuer 2016-01-13 07:10:56 EST
(In reply to Martin Stransky from comment #13)
> Hm I don't see anything wrong here. Do you see anything related in
> /var/log/messages? Also, can you try to "browser.download.useDownloadDir" to
> true?

There were log entries for dnf and PackageKit. System operation was normal in both Firefox builds.

I tried the "Refresh Firefox" in the about:support before submitting the bug. The "browser.download.x" settings were successfully reset when this operation was performed. The value for "browser.download.useDownloadDir" was reset to true. The "browser.download.lastDir" was reset to null. This did not resolve the issue.
Comment 16 Philip Heuer 2016-01-13 07:16:42 EST
(In reply to Martin Stransky from comment #14)
> That may be also a problem with your temporary dir (/tmp or /var/tmp). Do
> you have anything in dmesg?

These are operating properly. Entries provided by 'dmesg | grep tmp' are:

[    0.692921] devtmpfs: initialized
[    2.764107] audit: type=1130 audit(1452656098.387:2): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=kernel msg='unit=systemd-tmpfiles-setup-dev comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[    7.128663] audit: type=1130 audit(1452656102.754:77): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-tmpfiles-setup comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Comment 17 Philip Heuer 2016-01-13 20:53:12 EST
It looks like upstream fixed the issue in 43.0.4.

I locally rebuilt the 43.0.3-4 spec without patch 220 and substituted the new source0. The issue disappeared after upgrading from 43.0.3 to 43.0.4.
Comment 18 Martin Stransky 2016-01-14 04:56:49 EST
Ah, okay. Thanks for the info. New builds are in Koji.
Comment 19 Philip Heuer 2016-01-15 06:14:45 EST
The firefox-43.0.4-2.fc23 build in Koji works for me.
Comment 20 Martin Stransky 2016-01-25 08:14:06 EST
Interesting, thanks for the info.

Note You need to log in before you can comment on or make changes to this bug.