Bug 1297266 - [Docs][Upgrade][3.6] Upgrade Guide needs to cover how to upgrade RHEL6 clusters to RHEL 7 clusters for 3.5 cluster compatibility
[Docs][Upgrade][3.6] Upgrade Guide needs to cover how to upgrade RHEL6 cluste...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified
: ovirt-3.6.3
: ---
Assigned To: Dayle Parker
Julie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-10 22:13 EST by Julie
Modified: 2016-03-09 19:46 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 19:46:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Docs
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julie 2016-01-10 22:13:40 EST
The current upgrade instructions only cover updating el6 to the latest el6 and el7 to the latest el7. It should cover getting from el6 cluster to el7 cluster scenario for upgrading to 3.6 with 3.6 cluster compatibility version. 

Before BZ#1241149 is verified, users will need to follow the instructions similar to https://access.redhat.com/articles/1390733

Once BZ#1241149 is verified, just put the rhel6 host in the cluster into maintenance one by one and re-install it with rhel 7. My understanding is both re-installing and upgrading[1] are supported.

[1] https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Migration_Planning_Guide/chap-Red_Hat_Enterprise_Linux-Migration_Planning_Guide-Upgrading.html#chap-Red_Hat_Enterprise_Linux-Migration_Planning_Guide-Upgrading_from_RHEL6
Comment 1 Lucy Bopf 2016-01-25 00:33:17 EST
This bug tracks the addition of the manual cluster upgrade information in https://access.redhat.com/articles/1390733 to the Upgrade Guide, to provide users an upgrade path for GA. The new content should reference the detailed prerequisites for live migration available in the Virtual Machine Management Guide:
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6-Beta/html-single/Virtual_Machine_Management_Guide/index.html#sect-Migrating_Virtual_Machines_Between_Hosts

The in-cluster upgrade feature, when it becomes available, will be documented in bug 1301447.
Comment 2 Yaniv Lavi (Dary) 2016-02-09 07:59:06 EST
For the RHEV 3.6 GA we need the kbase to be in the guide without the in cluster process.
Comment 3 Lucy Bopf 2016-02-15 23:26:40 EST
Assigning to Dayle for review.

Dayle, see the instructions in Comment 1. The procedure from the kbase should be added to the Upgrade Guide, probably as a standalone topic. At the moment, because clusters in RHEV cannot include a mix of RHEL 6 and RHEL 7 hosts, this is the only way to upgrade hosts from RHEL 6 to RHEL 7 for RHEV 3.6 (which supports only RHEL 7 hosts).
Comment 5 Julie 2016-02-23 18:09:19 EST
I think this should be added to Chapter 3. Upgrading to Red Hat Enterprise Virtualization 3.6 as it is a task you need to do after you upgrade the Manager.

The work flow is like this:
1. Upgrade the Manager to 3.6 
2. Upgrade existing RHEL6 hosts as RHEL7.
---
Notes:
* live vm migration is mentioned so this can be done in production environments where you don't want to shut dowm the vm to perform a RHEL base OS upgrade
* For RHEV-H, you can upgrade RHEV-H 6 to RHEV-H 7 from the Administration Portal. 
* For RHEL-based hypervisors, advise users to reinstall or upgrade. I believe reinstalling is recommended as the upgrade path provided in the rhel guides are relatively complex.  
---
3. Post upgrade task- change cluster and data center computability version to 3.6.

Without step2, even though the Manager is upgraded to 3.6, the cluster and data center computability version can only remain at 3.5 as RHEL6 hosts are not supported in 3.6 compatibility. 

Please let me know if you have any questions.

Cheers,
Julie
Comment 6 Julie 2016-02-23 18:10:53 EST
sorry for the typos:
s/computability/compatibility
Comment 7 Dayle Parker 2016-02-24 03:29:35 EST
Hi Julie,

Thanks for the info. I've changed you to the QE contact on the merge request, as discussed, and I've edited the section quite a bit. I've added some extra steps to "Procedure 3.2. Live migrating virtual machines from a version 6 cluster to a version 7 cluster" for upgrading hosts, as well as some links. It's all in Git, ready to be checked.

However, two questions still:
* I can't find any instructions to upgrade a RHEV-H 6 host to a RHEV-H 7 host via the Admin Portal (and would like to add a link to a procedure if possible). Can you point me to something, or is the instruction here sufficient?

* Should we add a step about migrating VMs to another host while another host is being upgraded?

Thank you for reviewing,
Dayle
Comment 8 Julie 2016-02-24 20:15:48 EST
Hi Dayle,
  Upgrading RHEV-H 6 to 7 is the same as updating within the same major version so the instructions in https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6-Beta/html/Upgrade_Guide/Updating_Red_Hat_Enterprise_Virtualization_Hypervisors1.html apply. I have added the instructions in your procedure.

The vm migration step should be done before upgrading a host as you want the host to have no virtual load before upgrading or re-installing it. 

I have also update the ulink format to what was agreed on. 

Please have a look and see if you agree with the changes. Feel free to make edits. The content should cover what needs to be covered.

Thanks,
Julie
Comment 9 Dayle Parker 2016-02-24 20:50:56 EST
Hi Julie,

The changes you've made look excellent. 

It makes much more sense to migrate the VMs before upgrading the host. Many thanks for clarifying the text and answering my questions. 

Cheers,
Dayle
Comment 10 Julie 2016-02-24 22:07:13 EST
Added a revision history entry.
Moving this bug to VERIFIED.

Cheers,
Julie

Note You need to log in before you can comment on or make changes to this bug.