Bug 1297275 - Regression issue: For disperse volume on UI it doesnot show the rebalance option highlighted.
Regression issue: For disperse volume on UI it doesnot show the rebalance opt...
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
3.1
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Sahina Bose
Triveni Rao
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-10 23:49 EST by Triveni Rao
Modified: 2016-05-16 00:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 00:22:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (1.27 MB, image/png)
2016-01-10 23:50 EST, Triveni Rao
no flags Details

  None (edit)
Description Triveni Rao 2016-01-10 23:49:20 EST
Description of problem:
========================
Regression issue: For disperse volume on UI it doesnot show the rebalance option highlighted.

When EC(disperse volume 1*4+2)) created then after right click on the volume doesnot show rebalance option for that volume.

Version-Release number of selected component (if applicable):
=============================================================
rhsc-3.1.2-0.70.el6

How reproducible:
=================
Easily

Steps to Reproduce:
====================
1.Create disperse volume from back end;
eg: [root@dhcp35-3 ~]# gluster v create Disp disperse 6 10.70.35.42:/rhs/brick1/g1 10.70.35.3:/rhs/brick1/g1 10.70.35.42:/rhs/brick2/g1 10.70.35.3:/rhs/brick2/g1 10.70.35.42:/rhs/brick1/g2 10.70.35.3:/rhs/brick1/g2 force
The optimal redundancy for this configuration is 2. Do you want to create the volume with this value ? (y/n) y
volume create: Disp: success: please start the volume to access data
[root@dhcp35-3 ~]# 

2. Start the volume and check it in UI.
3. Rebalance option is not highlighted on the right click of the volume.

Actual results:
=================
For disperse volume on UI it doesnot show the rebalance option highlighted.

Expected results:
=================
Rebalance option should be highlighted.

Additional info:
================

[root@dhcp35-3 ~]# gluster v create Disp disperse 6 10.70.35.42:/rhs/brick1/g1 10.70.35.3:/rhs/brick1/g1 10.70.35.42:/rhs/brick2/g1 10.70.35.3:/rhs/brick2/g1 10.70.35.42:/rhs/brick1/g2 10.70.35.3:/rhs/brick1/g2 force
The optimal redundancy for this configuration is 2. Do you want to create the volume with this value ? (y/n) y
volume create: Disp: success: please start the volume to access data
[root@dhcp35-3 ~]# 
[root@dhcp35-3 ~]# 
[root@dhcp35-3 ~]# gluster v start Disp
volume start: Disp: success
[root@dhcp35-3 ~]# 
[root@dhcp35-3 ~]# gluster v info Disp
 
Volume Name: Disp
Type: Disperse
Volume ID: 3e4f1456-5d85-4d5a-a967-a6038b65a4f5
Status: Started
Number of Bricks: 1 x (4 + 2) = 6
Transport-type: tcp
Bricks:
Brick1: 10.70.35.42:/rhs/brick1/g1
Brick2: 10.70.35.3:/rhs/brick1/g1
Brick3: 10.70.35.42:/rhs/brick2/g1
Brick4: 10.70.35.3:/rhs/brick2/g1
Brick5: 10.70.35.42:/rhs/brick1/g2
Brick6: 10.70.35.3:/rhs/brick1/g2
Options Reconfigured:
performance.readdir-ahead: on
auto-delete: disable
snap-activate-on-create: disable
[root@dhcp35-3 ~]# 
[root@dhcp35-3 ~]# 
[root@dhcp35-3 ~]#
Comment 2 Triveni Rao 2016-01-10 23:50 EST
Created attachment 1113491 [details]
screen shot
Comment 3 Ramesh N 2016-01-11 00:22:46 EST
This is not a bug. Rebalance option is relevant for Distributed (Distributed Disperse, or Distributed Replicate or just Distributed) volumes only. See bz#1261516 for more info.

Note You need to log in before you can comment on or make changes to this bug.