Bug 1297384 - Templates not visible to subtenant after setting ownership to subtenant
Templates not visible to subtenant after setting ownership to subtenant
Status: CLOSED WORKSFORME
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity medium
: GA
: 5.6.0
Assigned To: Libor Pichler
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 06:14 EST by Aziza Karol
Modified: 2016-01-27 04:25 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-25 03:43:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sshveta: automate_bug? (akarol)


Attachments (Terms of Use)

  None (edit)
Description Aziza Karol 2016-01-11 06:14:27 EST
Description of problem:


Version-Release number of selected component (if applicable):
5.5.2.0.20151219144653_653c0d4

How reproducible:
100%

Steps to Reproduce:
1.Navigate to configure->Access control->tenants
3..For Tenant " My Company" create a project.
2. Create new group, assign project and EvmRole-tsuper_administrator role to it.
3. Create new user ex:"tenant"and assign group created in previous step to this user
4.change any infra template ownership to user "tenant".
5.login as tenant and navigate to infrastructure->virtual machines->templates

Actual results:
Templates does not get listed for user tenant

Expected results:
Templates should get listed for user tenant

Additional info:
Comment 2 Libor Pichler 2016-01-22 06:09:38 EST
Aziza, 

I have tried this scenario but I am not able to recreate it.
In step 4, I tried it with any group and with the group (from poing 2. Create new group, ) and with no group as well. For this 3 case I was still able to see the template.

Can you try it again please and confirm if issue is still here ?

Thank you!
Comment 3 Aziza Karol 2016-01-25 00:43:21 EST
Libor,
 
This issue is not reproducible in 5.5.2.1. The templates are visible to subtenant.
we can close this issue.

~Thanks,
Aziza
Comment 4 Libor Pichler 2016-01-25 03:43:05 EST
Closing, seem to be fixed already.

Note You need to log in before you can comment on or make changes to this bug.