Bug 1297452 - Scan alignment should not be allowed to run on running VMs
Scan alignment should not be allowed to run on running VMs
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.2
: 3.6.2.5
Assigned To: Tal Nisan
Aharon Canan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 09:47 EST by Tal Nisan
Modified: 2016-02-18 06:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:07:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tnisan: ovirt‑3.6.z?
rule-engine: planning_ack?
tnisan: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)
screenshot (366.40 KB, image/x-xcf)
2016-01-17 09:29 EST, Aharon Canan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51173 master MERGED core: Disallow scan alignment on running VM disks 2016-01-11 11:10 EST
oVirt gerrit 51654 master MERGED webadmin: Disallow scan alignment on running VM disks 2016-01-11 11:10 EST
oVirt gerrit 51666 ovirt-engine-3.6 MERGED core: Disallow scan alignment on running VM disks 2016-01-11 15:01 EST
oVirt gerrit 51667 ovirt-engine-3.6 MERGED webadmin: Disallow scan alignment on running VM disks 2016-01-11 15:02 EST
oVirt gerrit 51668 ovirt-engine-3.6.2 MERGED core: Disallow scan alignment on running VM disks 2016-01-11 15:05 EST
oVirt gerrit 51669 ovirt-engine-3.6.2 MERGED webadmin: Disallow scan alignment on running VM disks 2016-01-11 15:05 EST

  None (edit)
Description Tal Nisan 2016-01-11 09:47:20 EST
Description of problem:
Currently scan alignment can be run on VMs that are not down, since we run the scan directly and not through Libvirt this will cause a scan on a running VM to mark it as tainted

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Try to run a scan on an running VM
2.
3.

Actual results:
The scan starts

Expected results:
Scan should fail

Additional info:
Comment 1 Aharon Canan 2016-01-17 09:29:18 EST
Verified
========
rhevm-3.6.2.5-0.1.el6.noarch
vdsm-4.17.17-0.el7ev.noarch

Steps to Reproduce:
===================
Try to scan disk on an running VM

Results 
=======
right click on one of the disks - "Scan Alignment" grayed out.
Comment 2 Aharon Canan 2016-01-17 09:29 EST
Created attachment 1115609 [details]
screenshot

Note You need to log in before you can comment on or make changes to this bug.