Bug 1297516 - pkg_resources.DistributionNotFound: The 'jsonschema' distribution was not found and is required by docker-compose
pkg_resources.DistributionNotFound: The 'jsonschema' distribution was not fou...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: docker-compose (Show other bugs)
23
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Michael Hampton
Fedora Extras Quality Assurance
:
: 1298083 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 13:19 EST by Martín Cigorraga
Modified: 2016-01-20 16:54 EST (History)
3 users (show)

See Also:
Fixed In Version: docker-compose-1.5.2-4.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 16:54:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martín Cigorraga 2016-01-11 13:19:21 EST
Description of problem:
When trying to run docker-compose:
"pkg_resources.DistributionNotFound: The 'jsonschema' distribution was not found and is required by docker-compose"

Version-Release number of selected component (if applicable):
Name        : docker-compose
Arch        : noarch
Epoch       : 0
Version     : 1.5.2
Release     : 2.fc23
Size        : 351 k
Repo        : @System
From repo   : updates

How reproducible:
Always

Steps to Reproduce:
1. # docker-compose {build,up}
2.
3.

Actual results:
Docker-compose bails back to shell with the error message that gives the name to this topic.

Additional info:
Installing the missing 'python-jsonschema' package solves the issue (packaging error?)

HTH!
Comment 1 Fedora Update System 2016-01-11 15:39:20 EST
docker-compose-1.5.2-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7a3b274c5c
Comment 2 Michael Hampton 2016-01-11 15:57:18 EST
You're right, it was a silly packaging error. Sorry for the inconvenience.
Comment 3 Martín Cigorraga 2016-01-11 16:06:48 EST
Conversely, thanks for taking care of it Michael.
Comment 4 Fedora Update System 2016-01-12 04:52:39 EST
docker-compose-1.5.2-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7a3b274c5c
Comment 5 Fedora Update System 2016-01-12 08:56:06 EST
docker-compose-1.5.2-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-46b3b0f86f
Comment 6 Fedora Update System 2016-01-13 02:53:51 EST
docker-compose-1.5.2-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-46b3b0f86f
Comment 7 Michael Hampton 2016-01-13 07:47:29 EST
*** Bug 1298083 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2016-01-20 16:54:38 EST
docker-compose-1.5.2-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.