Bug 1297617 - [abrt] webkitgtk4: _gdk_window_has_impl(): WebKitPluginProcess killed by SIGSEGV
[abrt] webkitgtk4: _gdk_window_has_impl(): WebKitPluginProcess killed by SIGSEGV
Status: CLOSED DUPLICATE of bug 1243159
Product: Fedora
Classification: Fedora
Component: webkitgtk4 (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Popela
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:8feaeb1aef06ef446c28da9512b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 21:54 EST by Michael Catanzaro
Modified: 2016-03-01 18:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 18:51:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (35.53 KB, text/plain)
2016-01-11 21:54 EST, Michael Catanzaro
no flags Details
File: cgroup (190 bytes, text/plain)
2016-01-11 21:54 EST, Michael Catanzaro
no flags Details
File: core_backtrace (6.65 KB, text/plain)
2016-01-11 21:54 EST, Michael Catanzaro
no flags Details
File: dso_list (11.93 KB, text/plain)
2016-01-11 21:54 EST, Michael Catanzaro
no flags Details
File: environ (1.97 KB, text/plain)
2016-01-11 21:54 EST, Michael Catanzaro
no flags Details
File: limits (1.29 KB, text/plain)
2016-01-11 21:54 EST, Michael Catanzaro
no flags Details
File: maps (55.41 KB, text/plain)
2016-01-11 21:54 EST, Michael Catanzaro
no flags Details
File: mountinfo (3.63 KB, text/plain)
2016-01-11 21:54 EST, Michael Catanzaro
no flags Details
File: namespaces (85 bytes, text/plain)
2016-01-11 21:54 EST, Michael Catanzaro
no flags Details
File: open_fds (1.45 KB, text/plain)
2016-01-11 21:54 EST, Michael Catanzaro
no flags Details
File: proc_pid_status (1.00 KB, text/plain)
2016-01-11 21:54 EST, Michael Catanzaro
no flags Details
File: var_log_messages (28 bytes, text/plain)
2016-01-11 21:54 EST, Michael Catanzaro
no flags Details

  None (edit)
Description Michael Catanzaro 2016-01-11 21:54:06 EST
Version-Release number of selected component:
webkitgtk4-2.10.4-1.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/libexec/webkit2gtk-4.0/WebKitPluginProcess 37 /usr/lib64/mozilla/plugins/libnpgoogletalk.so
crash_function: _gdk_window_has_impl
executable:     /usr/libexec/webkit2gtk-4.0/WebKitPluginProcess
global_pid:     14669
kernel:         4.2.8-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 _gdk_window_has_impl at gdkwindow.c:626
 #1 gdk_x11_window_get_xid at gdkwindow-x11.c:5527
 #2 WebKit::NetscapePlugin::platformGeometryDidChange at /usr/src/debug/webkitgtk-2.10.4/Source/WebKit2/WebProcess/Plugins/Netscape/x11/NetscapePluginX11.cpp:255
 #3 WebKit::NetscapePlugin::geometryDidChange at /usr/src/debug/webkitgtk-2.10.4/Source/WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.cpp:810
 #4 WebKit::PluginControllerProxy::geometryDidChange at /usr/src/debug/webkitgtk-2.10.4/Source/WebKit2/PluginProcess/PluginControllerProxy.cpp:429
 #5 IPC::callMemberFunctionImpl<WebKit::PluginControllerProxy, void (WebKit::PluginControllerProxy::*)(WebCore::IntSize const&, WebCore::IntRect const&, WebCore::AffineTransform const&, float, WebKit::ShareableBitmap::Handle const&), std::tuple<WebCore::IntSize, WebCore::IntRect, WebCore::AffineTransform, float, WebKit::ShareableBitmap::Handle>, 0ul, 1ul, 2ul, 3ul, 4ul>(WebKit::PluginControllerProxy*, void (WebKit::PluginControllerProxy::*)(WebCore::IntSize const&, WebCore::IntRect const&, WebCore::AffineTransform const&, float, WebKit::ShareableBitmap::Handle const&), std::tuple<WebCore::IntSize, WebCore::IntRect, WebCore::AffineTransform, float, WebKit::ShareableBitmap::Handle>&&, std::index_sequence<0ul, 1ul, 2ul, 3ul, 4ul>) at /usr/src/debug/webkitgtk-2.10.4/Source/WebKit2/Platform/IPC/HandleMessage.h:16
 #6 IPC::callMemberFunction<WebKit::PluginControllerProxy, void (WebKit::PluginControllerProxy::*)(WebCore::IntSize const&, WebCore::IntRect const&, WebCore::AffineTransform const&, float, WebKit::ShareableBitmap::Handle const&), std::tuple<WebCore::IntSize, WebCore::IntRect, WebCore::AffineTransform, float, WebKit::ShareableBitmap::Handle>, std::make_index_sequence<5ul> >(std::tuple<WebCore::IntSize, WebCore::IntRect, WebCore::AffineTransform, float, WebKit::ShareableBitmap::Handle>&&, WebKit::PluginControllerProxy*, void (WebKit::PluginControllerProxy::*)(WebCore::IntSize const&, WebCore::IntRect const&, WebCore::AffineTransform const&, float, WebKit::ShareableBitmap::Handle const&)) at /usr/src/debug/webkitgtk-2.10.4/Source/WebKit2/Platform/IPC/HandleMessage.h:22
 #7 IPC::handleMessage<Messages::PluginControllerProxy::GeometryDidChange, WebKit::PluginControllerProxy, void (WebKit::PluginControllerProxy::*)(WebCore::IntSize const&, WebCore::IntRect const&, WebCore::AffineTransform const&, float, WebKit::ShareableBitmap::Handle const&)> at /usr/src/debug/webkitgtk-2.10.4/Source/WebKit2/Platform/IPC/HandleMessage.h:92
 #8 WebKit::PluginControllerProxy::didReceivePluginControllerProxyMessage at /usr/src/debug/webkitgtk-2.10.4/x86_64-redhat-linux-gnu/DerivedSources/WebKit2/PluginControllerProxyMessageReceiver.cpp:49
 #9 WebKit::WebProcessConnection::didReceiveMessage at /usr/src/debug/webkitgtk-2.10.4/Source/WebKit2/PluginProcess/WebProcessConnection.cpp:141

Potential duplicate: bug 1243159
Comment 1 Michael Catanzaro 2016-01-11 21:54:11 EST
Created attachment 1113781 [details]
File: backtrace
Comment 2 Michael Catanzaro 2016-01-11 21:54:13 EST
Created attachment 1113782 [details]
File: cgroup
Comment 3 Michael Catanzaro 2016-01-11 21:54:14 EST
Created attachment 1113783 [details]
File: core_backtrace
Comment 4 Michael Catanzaro 2016-01-11 21:54:15 EST
Created attachment 1113784 [details]
File: dso_list
Comment 5 Michael Catanzaro 2016-01-11 21:54:16 EST
Created attachment 1113785 [details]
File: environ
Comment 6 Michael Catanzaro 2016-01-11 21:54:17 EST
Created attachment 1113786 [details]
File: limits
Comment 7 Michael Catanzaro 2016-01-11 21:54:19 EST
Created attachment 1113787 [details]
File: maps
Comment 8 Michael Catanzaro 2016-01-11 21:54:20 EST
Created attachment 1113788 [details]
File: mountinfo
Comment 9 Michael Catanzaro 2016-01-11 21:54:21 EST
Created attachment 1113789 [details]
File: namespaces
Comment 10 Michael Catanzaro 2016-01-11 21:54:22 EST
Created attachment 1113790 [details]
File: open_fds
Comment 11 Michael Catanzaro 2016-01-11 21:54:22 EST
Created attachment 1113791 [details]
File: proc_pid_status
Comment 12 Michael Catanzaro 2016-01-11 21:54:23 EST
Created attachment 1113792 [details]
File: var_log_messages
Comment 13 Michael Catanzaro 2016-03-01 18:51:06 EST

*** This bug has been marked as a duplicate of bug 1243159 ***

Note You need to log in before you can comment on or make changes to this bug.