Bug 129766 - Identify if PyXML is still needed in the distro
Identify if PyXML is still needed in the distro
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: PyXML (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-12 12:06 EDT by Mihai Ibanescu
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-06 17:12:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mihai Ibanescu 2004-08-12 12:06:43 EDT
Parts of PyXML were merged into mainline python since python 2.2 (at
least).
Should identify if PyXML is still needed, or what Python offers is enough.
Comment 1 Miloslav Trmač 2004-09-06 17:12:28 EDT
Looking only at 'import' statements in packages that require PyXML:


system-config-printer:
* util/printconf_conf:
  xml.utils/qp_xml

4Suite:
* test/:
  xml.sax/saxexts
  xml.dom/ext
  xml.dom.Range/Range
  xml.unicode.iso8859
* demos/:
  xml.dom.ext
* Ft/Xml/Xslt/SaxWriter.py:
  xml.dom.ext.reader/{Sax,Sax2,HtmlSax}
* Ft/Xml/FtMiniDom/ValReader.py:
  xml.parsers/xmlproc
* Ft/ThirdParty/Xvif/iFrameRNG.py:
  xml.dom.ext.reader.Saxv2/XmlDomGenerator
* Ft/ThirdParty/Xvif/iFrameRegFrag.py:
  xml.dom.ext.reader.Saxv2/XmlDomGenerator
  xml.dom.ext.Dom2Sax/Dom2SaxParser
* Ft/ThirdParty/Xvif/iFrameTypes.py:
  xml.dom.ext.reader.Saxv2/XmlDomGenerator
* Ft/ThirdParty/Xvif/iFrameXSLT.py:
  xml.dom.ext.reader.Saxv2/XmlDomGenerator
* Ft/ThirdParty/Xvif/iframe.py:
  xml.dom.ext.reader.Saxv2/XmlDomGenerator


So it looks like we can't remove it yet.

Note You need to log in before you can comment on or make changes to this bug.