Bug 1297677 - Packages python-enum34 is required by Docker Compose
Packages python-enum34 is required by Docker Compose
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: docker-compose (Show other bugs)
23
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Michael Hampton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 03:37 EST by Thomas Gerbet
Modified: 2016-01-20 16:54 EST (History)
4 users (show)

See Also:
Fixed In Version: docker-compose-1.5.2-4.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 16:54:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Gerbet 2016-01-12 03:37:26 EST
Package python-enum34 is required by Docker Compose and when you try to run without it, you get the following message:
pkg_resources.DistributionNotFound: The 'enum34' distribution was not found and is required by docker-compose

You can get the error with Docker Compose 1.5.2-2.fc23, Docker Compose 1.5.2-3.fc23 does not solve the issue either.


This is the same packaging mistake than in https://bugzilla.redhat.com/show_bug.cgi?id=1297516
Comment 1 Fedora Update System 2016-01-12 08:56:00 EST
docker-compose-1.5.2-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-46b3b0f86f
Comment 2 Fedora Update System 2016-01-13 02:53:48 EST
docker-compose-1.5.2-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-46b3b0f86f
Comment 3 Fedora Update System 2016-01-20 16:54:35 EST
docker-compose-1.5.2-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.