Bug 12977 - ld.so broken
Summary: ld.so broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: binutils (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-24 02:51 UTC by Suhaib Siddiqi
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-09 02:42:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Suhaib Siddiqi 2000-06-24 02:51:02 UTC
Beta-2 seems to have broken binary compability for some applications
compiled on RedHat 6.2 using GCC 2.95.2.

These applications workd on Beta-1, but on Beta-2, I get the following
error.

[root@hunda lib]# dx
BUG IN DYNAMIC LINKER ld.so: dl-version.c: 217: _dl_check_map_versions:
Assertion `needed != ((void *)0)' failed!


Looks like some MOTIF applications would need recompilation.

Comment 1 Cristian Gafton 2000-08-09 02:42:19 UTC
assigned to jakub

Comment 2 Jakub Jelinek 2000-08-25 15:58:11 UTC
It was actually a bug in binutils which resulted in wrong ELF images which glibc
complains about. This bug is fixed in the binutils in the current tree (RC1
and above for sure, probably much longer).


Note You need to log in before you can comment on or make changes to this bug.