Bug 1297719 - Azure Provider logo is inconsistent
Azure Provider logo is inconsistent
Status: CLOSED WORKSFORME
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity medium
: Beta 2
: 5.6.0
Assigned To: Bronagh Sorota
Jeff Teehan
ui:azure
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 05:13 EST by Christian Jung
Modified: 2016-10-03 12:16 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-28 14:08:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Azure


Attachments (Terms of Use)
Shows Azure icon on instances (294.24 KB, image/png)
2016-04-28 10:43 EDT, Bronagh Sorota
no flags Details

  None (edit)
Description Christian Jung 2016-01-12 05:13:44 EST
Description of problem:
The Provider Logo for Azure is not consistent between different views. The Provider overview page is using a different icon than the instance overview page.

See attached screenshots.

Version-Release number of selected component (if applicable):
5.5

How reproducible:
always

Steps to Reproduce:
1. Add an Azure Provider
2. navigate to the provider overview page
3. navigate to the instance overview page

Actual results:
Windows icon is not consistent

Expected results:


Additional info:
Comment 4 Christian Jung 2016-01-12 05:16:12 EST
I just noticed, you can also see the inconsistency in the instance overview page. Note the icon on the left and the icon used by the instance tiles.
Comment 7 Greg Blomquist 2016-01-18 13:21:37 EST
Hey Christian,

the vendor name was only recently fixed (https://github.com/ManageIQ/manageiq/pull/5717/files#diff-1f54967e2f7cd1793ef76031aa337270R228).  This fix should be in 5.5.2.

Can you double check that?

It's possible that we will need to include a database migration for this if you have existing VMs with a mis-encoded vendor value.
Comment 8 Peter McGowan 2016-01-20 05:34:24 EST
I can confirm that the vm.vendor attribute is 'Microsoft'.
Comment 9 Bronagh Sorota 2016-04-28 10:43 EDT
Created attachment 1151936 [details]
Shows Azure icon on instances
Comment 10 Bronagh Sorota 2016-04-28 10:53:44 EDT
Hi Christian,
I cannot reproduce this bug. The VM vendor property is set to "Azure":
https://github.com/ManageIQ/manageiq/blob/master/app/models/manageiq/providers/azure/cloud_manager/refresh_parser.rb#L209

I see the Azure icon displayed in the instance and provider views of the UI, see attached screenshot.
Can you reach out to me directly to discuss?

Thanks
Bronagh
Comment 11 Christian Jung 2016-05-11 14:32:23 EDT
HiHo,
yes, looks like it has been fixed since the original bug was reported.

Thanks,
Christian
Comment 12 Jeff Teehan 2016-07-27 01:40:09 EDT
Just assigning qe to myself in case it comes back.

Note You need to log in before you can comment on or make changes to this bug.