Bug 1297790 - Unable to evaluate the execution of 'openstack service '
Unable to evaluate the execution of 'openstack service '
Status: CLOSED WORKSFORME
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 6.0 (Juno)
Assigned To: Ivan Chavero
yeylon@redhat.com
: Automation, AutomationBlocker, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 08:19 EST by Arie Bregman
Modified: 2016-04-18 03:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-11 10:06:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arie Bregman 2016-01-12 08:19:29 EST
Description of problem:
Whenever I run packstack installation I get:

172.16.32.62_keystone.pp:                         [ ERROR ]
10:24:26 Applying Puppet manifests                         [ ERROR ]
10:24:26 
10:24:26 ERROR : Error appeared during Puppet run: x.x.x.x_keystone.pp
10:24:26 Error: /Stage[main]/Neutron::Keystone::Auth/Keystone_service[neutron]: Could not evaluate: Execution of '/usr/bin/openstack service list --quiet --format csv --long --os-token 335a9f885b6e411f89e293e35e9f526d --os-url http://127.0.0.1:35357/v2.0/' returned 1: Traceback (most recent call last):
10:24:26 You will find full trace in log /var/tmp/packstack/20160112-052001-Ey91Tf/manifests/x.x.x.x_keystone.pp.log
10:24:26 
Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Run packstack allinone installation


Actual results:
Error: /Stage[main]/Neutron::Keystone::Auth/Keystone_service[neutron]: Could not evaluate: Execution of '/usr/bin/openstack service list --quiet --format csv --long --os-token 335a9f885b6e411f89e293e35e9f526d --os-url

Expected results:
**** Installation completed successfully ******

Additional info:
Using poodle
Comment 2 Ivan Chavero 2016-02-11 10:06:24 EST
Could not reproduce with current packstack version, please feel free to reopen this bug if the problem persists.

Note You need to log in before you can comment on or make changes to this bug.