Bug 1297961 - Insights states the appliance is not registered to Red Hat when it is.
Insights states the appliance is not registered to Red Hat when it is.
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Red Hat Access (Show other bugs)
5.5.0
All All
high Severity medium
: GA
: cfme-future
Assigned To: Lindani Phiri
Satyajit Bulage
access
: ZStream
Depends On:
Blocks: 1309905 1346998
  Show dependency treegraph
 
Reported: 2016-01-12 16:23 EST by Josh Carter
Modified: 2017-08-28 11:03 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1309905 1346998 (view as bug list)
Environment:
Last Closed: 2017-08-28 10:46:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Carter 2016-01-12 16:23:40 EST
Description of problem:

Can not use Red Hat Insights.  Receive the following message:   This appliance is not registered to Red Hat.
The appliance is registered and subscribed to Red Hat.

Appliance shows fully registered 

+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Software Collections (for RHEL Server)
Product ID:     201
Version:        2
Arch:           x86_64
Status:         Subscribed
Status Details: 
Starts:         02/01/2015
Ends:           01/31/2016

Product Name:   Red Hat Enterprise Linux Server
Product ID:     69
Version:        7.1
Arch:           x86_64
Status:         Subscribed
Status Details: 
Starts:         02/01/2015
Ends:           01/31/2016

Product Name:   Red Hat CloudForms
Product ID:     167
Version:        4.0
Arch:           x86_64
Status:         Subscribed
Status Details: 
Starts:         02/01/2015
Ends:           01/31/2016



You can see the user attempting to access Red Hat Insights in the production log. 


[----] I, [2016-01-12T15:52:01.480202 #3025:d0b998]  INFO -- : Started GET
"/redhat_access/insights/rules" for 127.0.0.1 at 2016-01-12 15:52:01 -0500
[----] I, [2016-01-12T15:52:01.481988 #3025:d0b998]  INFO -- : Processing
by RedhatAccessCfme::InsightsController#index as HTML
[----] I, [2016-01-12T15:52:01.482060 #3025:d0b998]  INFO -- :
Parameters: {"path"=>"rules"}
[----] I, [2016-01-12T15:52:01.517310 #3025:d0b998]  INFO -- :   Rendered
/opt/rh/rh-ruby22/root/usr/share/gems/gems/redhat_access_cfme-0.0.7/app/views/redhat_access_cfme/insights/index.html.haml
within layouts/redhat_access_cfme/application (6.6ms)
[----] I, [2016-01-12T15:52:01.525582 #3025:d0b998]  INFO -- : Completed
200 OK in 43ms (Views: 7.8ms | ActiveRecord: 2.1ms)
[----] I, [2016-01-12T15:52:01.528937 #3025:d0b998]  INFO -- : Started GET
"/assets/patternfly/OpenSans-Regular-webfont.woff" for 127.0.0.1 at
2016-01-12 15:52:01 -0500
[----] I, [2016-01-12T15:52:01.535201 #3025:d0b998]  INFO -- : Started GET
"/assets/patternfly/PatternFlyIcons-webfont.ttf" for 127.0.0.1 at
2016-01-12 15:52:01 -0500




But nothing is logged to the appliance log to troubleshoot the issue further. 

Version-Release number of selected component (if applicable): 5.5.0


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Lindani Phiri 2016-01-13 06:05:54 EST
Looks like you registered the appliance using the console, and not the UI.

There is a limitation of the way that registrations currently work in CloudForms. Registering the appliance at the operation system level via the console using subscription-manager does not update the VMDB. The Insights subsystem is checking for registration status in the VMDB.

You must register via the UI for Insights to work. (Configure → Configuration. Select Region in the accordion menu and click Red Hat Updates). (See https://access.redhat.com/insights/getting-started/cloudforms/#registerappliance)

FYI, the logs for Insights go into evm.log
Comment 3 Josh Carter 2016-01-13 09:36:12 EST
"There is a limitation of the way that registrations currently work in CloudForms. Registering the appliance at the operation system level via the console using subscription-manager does not update the VMDB. The Insights subsystem is checking for registration status in the VMDB.

You must register via the UI for Insights to work. (Configure → Configuration. Select Region in the accordion menu and click Red Hat Updates). (See https://access.redhat.com/insights/getting-started/cloudforms/#registerappliance)"

The appliance can pick up either a registration process via the UI or via the cmd. There is a schedule that runs every 12 hours to check the registration status and then update the vmdb. 

What table and column are you monitoring for a successful registration status? 

This customers appliance has been running multiple days.

"FYI, the logs for Insights go into evm.log" I was unable to find anything on my lab appliance that shows insights or the customers appliance that is displaying this problem. Can you provide some of the recurring log lines that should be generated by insights?
Comment 4 Lindani Phiri 2016-02-12 11:26:02 EST
I am still not able to reproduce this issue in the lab.
Still investigating.
Comment 8 Chris Pelland 2017-08-28 10:46:11 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.