Bug 1298083 - [abrt] docker-compose: __init__.py:839:resolve:DistributionNotFound: The 'jsonschema' distribution was not found and is required by docker-compose
[abrt] docker-compose: __init__.py:839:resolve:DistributionNotFound: The 'jso...
Status: CLOSED DUPLICATE of bug 1297516
Product: Fedora
Classification: Fedora
Component: docker-compose (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Hampton
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:cb4143107242efeb4c5aeba1a34...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 03:34 EST by Yajo
Modified: 2016-01-13 07:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-13 07:47:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.61 KB, text/plain)
2016-01-13 03:34 EST, Yajo
no flags Details
File: environ (1.02 KB, text/plain)
2016-01-13 03:34 EST, Yajo
no flags Details

  None (edit)
Description Yajo 2016-01-13 03:34:38 EST
Version-Release number of selected component:
docker-compose-1.5.2-2.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python2 /usr/bin/docker-compose -f development.yml up -d
dso_list:       python-setuptools-18.0.1-2.fc23.noarch
executable:     /usr/bin/docker-compose
kernel:         4.2.8-300.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
__init__.py:839:resolve:DistributionNotFound: The 'jsonschema' distribution was not found and is required by docker-compose

Traceback (most recent call last):
  File "/usr/bin/docker-compose", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3084, in <module>
    @_call_aside
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3070, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3097, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 651, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 952, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 839, in resolve
    raise DistributionNotFound(req, requirers)
DistributionNotFound: The 'jsonschema' distribution was not found and is required by docker-compose

Local variables in innermost frame:
dist: None
requirers: set(['docker-compose'])
to_activate: [docker-compose 1.5.2 (/usr/lib/python2.7/site-packages), enum34 1.0.4 (/usr/lib/python2.7/site-packages)]
req: Requirement.parse('jsonschema')
requirements: [Requirement.parse('six'), Requirement.parse('dockerpty'), Requirement.parse('docker-py'), Requirement.parse('websocket-client'), Requirement.parse('texttable'), Requirement.parse('requests'), Requirement.parse('PyYAML'), Requirement.parse('docopt')]
new_requirements: []
replace_conflicting: False
required_by: defaultdict(<type 'set'>, {Requirement.parse('enum34'): set(['docker-compose']), Requirement.parse('texttable'): set(['docker-compose']), Requirement.parse('docker-py'): set(['docker-compose']), Requirement.parse('six'): set(['docker-compose']), Requirement.parse('jsonschema'): set(['docker-compose']), Requirement.parse('websocket-client'): set(['docker-compose']), Requirement.parse('dockerpty'): set(['docker-compose']), Requirement.parse('docopt'): set(['docker-compose']), Requirement.parse('PyYAML'): set(['docker-compose']), Requirement.parse('requests'): set(['docker-compose'])})
ws: <pkg_resources.WorkingSet object at 0x7fdf1f817850>
new_requirement: Requirement.parse('docopt')
env: <pkg_resources.Environment object at 0x7fdf1f817890>
installer: None
self: <pkg_resources.WorkingSet object at 0x7fdf1f817850>
best: {'jsonschema': None}
processed: {Requirement.parse('enum34'): True, Requirement.parse('docker-compose==1.5.2'): True}
Comment 1 Yajo 2016-01-13 03:34:43 EST
Created attachment 1114307 [details]
File: backtrace
Comment 2 Yajo 2016-01-13 03:34:45 EST
Created attachment 1114308 [details]
File: environ
Comment 3 Yajo 2016-01-13 03:40:00 EST
Workaround:

sudo dnf install python-jsonschema
Comment 4 Michael Hampton 2016-01-13 07:47:29 EST

*** This bug has been marked as a duplicate of bug 1297516 ***

Note You need to log in before you can comment on or make changes to this bug.