Bug 1298266 - Recommended values for tiering : minfree disk and water mark [NEEDINFO]
Recommended values for tiering : minfree disk and water mark
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: doc-Administration_Guide (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Divya
storage-qa-internal@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 11:01 EST by Vivek Agarwal
Modified: 2016-02-02 04:23 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-02 04:23:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
divya: needinfo? (byarlaga)


Attachments (Terms of Use)

  None (edit)
Description Vivek Agarwal 2016-01-13 11:01:53 EST
Document URL: 

We need to document the recommended values for minfree disk and water mark (high and low) to ensure the hot tier is never full.

Hot tier getting full has lead to lot of issues during testing.

Section Number and Name: 

Describe the issue: 

Suggestions for improvement: 

Additional information:
Comment 2 Vivek Agarwal 2016-01-13 11:02:55 EST
Please provide the recommended values
Comment 3 Dan Lambright 2016-01-13 11:20:51 EST
Believe 90% is the right number for both the watermark and min-free-disk. Will confirm with team.
Comment 5 Dan Lambright 2016-01-13 13:53:56 EST
Yes, in the tiering chapter, we could say those are the default values and the ones Red Hat recommends. Assuming these numbers work with PM and dev.
Comment 6 Divya 2016-01-13 23:16:30 EST
Options "cluster.watermark-hi" and "cluster.watermark-low" is already documented [1]. The default value for "cluster.watermark-hi" is 90% and allowed values are 1-99%. The default value for "cluster.watermark-low" is 75% and allowed values are 1-99%. 

"cluster.min-free-disk" is already documented [1].

The recommended values will usually be the default values. Do we still need to add a note that the default values are the recommended values? 

Also, please let me know if I have to document any other option.

[1] http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-3.1-Administration_Guide%20%28html-single%29/lastStableBuild/artifact/tmp/en-US/html-single/index.html#Configuring_Volume_Options
Comment 7 Dan Lambright 2016-01-14 06:33:23 EST
I was answering the NEEDINFO for comment #2. I do not think we need to modify the documentation given comment #6. Can this bug be closed ?
Comment 8 Divya 2016-01-14 06:43:09 EST
Raising a Need_Info on Vivek (Bug Reporter) to review Comment 3, Comment 6 and Comment 7 and then close the bug.
Comment 9 Vivek Agarwal 2016-01-14 07:28:22 EST
Well this was an AI on me from one of the calls, Bhaskarkiran followed up and hence I filed this. We can close this, if the same is documented else where.
Comment 10 Divya 2016-01-20 01:20:50 EST
Based on Comment 9, raising need_info on Bhaskarkiran.

Bhaskarkiran,

Could you review the comments in the bug and share your thoughts.
Comment 11 Bhaskarakiran 2016-02-02 04:22:32 EST
Since we have not received any new values for both. we can close this out.
Comment 12 Divya 2016-02-02 04:23:15 EST
Based on Comment 11, closing this bug.

Note You need to log in before you can comment on or make changes to this bug.