Bug 1298294 - strace fails to build on s390 architecture due to test failure
strace fails to build on s390 architecture due to test failure
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: strace (Show other bugs)
rawhide
s390 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dmitry V. Levin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 11:45 EST by Sinny Kumari
Modified: 2016-01-15 12:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-15 12:14:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sinny Kumari 2016-01-13 11:45:22 EST
strace fails to build on Fedora rawhide, s390 architecture because of membarrier, userfaultfd, mlock2 and sigreturn tests failure.
Koji build link containing build failure details- http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2047711

Version-Release number of selected component (if applicable):
strace-4.11-2.fc24

Additional info:
Test membarrier, userfaultfd and mlock2 also fails on s390x architecture.
Comment 1 Sinny Kumari 2016-01-13 11:53:30 EST
Few observations
---------------
* Building strace-4.11-2 on Fedora 23 causes only sigreturn test failure and tests membarrier, userfaultfd, mlock2 get skipped.
Koji build link - http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2051484
* Test failures are reproducible easily if built in koji. I couldn't reproduce these tests failures locally using mock.
Comment 2 Dmitry V. Levin 2016-01-13 11:59:12 EST
(In reply to Sinny Kumari from comment #0)
> strace fails to build on Fedora rawhide, s390 architecture because of
> membarrier, userfaultfd, mlock2 and sigreturn tests failure.

Decoding of s390 sigreturn on recent kernels was fixed upstream by commit v4.11-149-g8493dcf. strace used to workaround a kernel bug on s390, for kernels containing commit v4.3-rc1-50-g8d4bd0e this workaround has to be reverted.
Comment 3 Dmitry V. Levin 2016-01-13 20:12:17 EST
(In reply to Sinny Kumari from comment #0)
> strace fails to build on Fedora rawhide, s390 architecture because of
> membarrier, userfaultfd, mlock2 and sigreturn tests failure.
[...]
> Test membarrier, userfaultfd and mlock2 also fails on s390x architecture.

Decoding of syscalls unrecognized by the kernel on s390/s390x was fixed by upstream commit v4.11-159-g1763fa5.

Successful scratch build: http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2051509
Comment 4 Sinny Kumari 2016-01-14 04:24:51 EST
Thanks Dmitry for the quick fix. With this fix, strace builds successfully on F23 and Fedora rawhide.

It will be great to have a new release of strace having these fixes included. Any plan to do a new release soon?
Comment 5 Dmitry V. Levin 2016-01-14 22:41:55 EST
(In reply to Sinny Kumari from comment #4)
> It will be great to have a new release of strace having these fixes
> included. Any plan to do a new release soon?

There are several test failures on Debian secondary architectures as well.
I'd like to do a bugfix release once they are fixed.
Comment 6 Dan Horák 2016-01-15 03:23:18 EST
Could you build an updated package with just the s390 fix for Rawhide? Or I can do the update as a provenpackager if you won't object. strace is used in buildroots for important packages like coreutils and thus is blocking building Rawhide for s390(x).
Comment 7 Dmitry V. Levin 2016-01-15 12:14:48 EST
(In reply to Dan Horák from comment #6)
> Could you build an updated package with just the s390 fix for Rawhide?

I've submitted snapshot v4.11-163-g972018f to Rawhide.
Comment 8 Dan Horák 2016-01-15 12:45:53 EST
Thanks a lot, successfully built in s390 koji  - http://s390.koji.fedoraproject.org/koji/buildinfo?buildID=369766

Note You need to log in before you can comment on or make changes to this bug.