Bug 1298409 - Missing tar dependency
Missing tar dependency
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ansible (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 19:52 EST by Brad Durrow
Modified: 2016-01-13 23:13 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-13 23:13:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Durrow 2016-01-13 19:52:03 EST
Description of problem:
When using the unarchive module ansible appears to call /usr/bin/gtar (at least on EL7) but there is no Requires: tar line in the spec.

Version-Release number of selected component (if applicable):
1.9.4.1.el7

How reproducible:
100%

Steps to Reproduce:
1. I don't know how to reproduce this because all of my images have tar already installed.   

Additional info:
I initially thought the problem I had was that tar wasn't installed but I later figured out that the destination directory didn't exist.  I thought you might want to include this for completeness.  I assume build will also require tar because the source is currently downloaded in a tar ball.
Comment 1 Kevin Fenzi 2016-01-13 23:13:49 EST
So, we don't actually add requires to the package for module needs. 

Modules run on any arbitrary hosts you are managing, so a requires wouldn't help any there (they likely won't have ansible package installed). They could help on the management host itself, but if we required everything from every module there it would bloat the ansible package footprint gigantically for almost no gain. 

If the error the module returns is poor, we should look at making a upstream change to the module to make it more clear what the host needs to have installed.

Note You need to log in before you can comment on or make changes to this bug.