Bug 1298495 - [abrt] dnf: base.py:134:_add_repo_to_sack:AssertionError: Can not load repo.
[abrt] dnf: base.py:134:_add_repo_to_sack:AssertionError: Can not load repo.
Status: CLOSED DUPLICATE of bug 1295219
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:80f10b4187823babf38774f345c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 04:35 EST by QubesFan
Modified: 2016-01-19 09:34 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 09:34:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (949.05 KB, text/plain)
2016-01-14 04:35 EST, QubesFan
no flags Details
File: backtrace (1.12 KB, text/plain)
2016-01-14 04:35 EST, QubesFan
no flags Details
File: environ (86 bytes, text/plain)
2016-01-14 04:36 EST, QubesFan
no flags Details

  None (edit)
Description QubesFan 2016-01-14 04:35:45 EST
Version-Release number of selected component:
dnf-1.1.5-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 /usr/bin/dnf -q check-update
dnf-makecache.log: -- No entries --
executable:     /usr/bin/dnf
kernel:         4.1.13-8.pvops.qubes.x86_64
runlevel:       N 3
type:           Python3
uid:            0

Truncated backtrace:
base.py:134:_add_repo_to_sack:AssertionError: Can not load repo.

Traceback (most recent call last):
  File "/usr/bin/dnf", line 57, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 112, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1094, in run
    self._process_demands()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 810, in _process_demands
    load_available_repos=lar)
  File "/usr/lib/python3.4/site-packages/dnf/base.py", line 256, in fill_sack
    self._add_repo_to_sack(r.id)
  File "/usr/lib/python3.4/site-packages/dnf/base.py", line 134, in _add_repo_to_sack
    load_updateinfo=True)
AssertionError: Can not load repo.

Local variables in innermost frame:
self: <dnf.cli.cli.BaseCli object at 0x7ff0aba7a6a0>
hrepo: <_hawkey.Repo object at 0x7ff0abbaed98>
repo: <Repo fedora>
name: 'fedora'
Comment 1 QubesFan 2016-01-14 04:35:56 EST
Created attachment 1114737 [details]
File: _var_log_dnf.log
Comment 2 QubesFan 2016-01-14 04:35:58 EST
Created attachment 1114738 [details]
File: backtrace
Comment 3 QubesFan 2016-01-14 04:36:00 EST
Created attachment 1114739 [details]
File: environ
Comment 4 Honza Silhan 2016-01-19 09:34:05 EST

*** This bug has been marked as a duplicate of bug 1295219 ***

Note You need to log in before you can comment on or make changes to this bug.