This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1298529 - CRUD of Tenants and Projects - flash messages are not accurate
CRUD of Tenants and Projects - flash messages are not accurate
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity low
: GA
: cfme-future
Assigned To: lgalis
Pavol Kotvan
ui:tenant_cfme
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 06:23 EST by Pavol Kotvan
Modified: 2017-08-21 09:08 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-21 09:05:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Case 1 screenshot (20.44 KB, image/png)
2016-01-14 06:23 EST, Pavol Kotvan
no flags Details
Case 2 screenshot (29.73 KB, image/png)
2016-01-14 06:24 EST, Pavol Kotvan
no flags Details
Case 3 screenshot (29.67 KB, image/png)
2016-01-14 06:25 EST, Pavol Kotvan
no flags Details

  None (edit)
Description Pavol Kotvan 2016-01-14 06:23:05 EST
Created attachment 1114753 [details]
Case 1 screenshot

Description of problem:
When updating/deleting tenants/projects, flash message contain wrong description of what action happened. E.g. when updating tenant - Project "$(name_of_tenant)" was saved message is displayed, which is wrong, because tenant was updated, not project. 


Version-Release number of selected component (if applicable):
5.5.2.0.20151219144653_653c0d4 

How reproducible:
always

Steps to Reproduce:
Case 1) Update of tenant:
1. Create new tenant
     name: tenant6
     description: tenant6 desc
2. Update tenant6 and change e.g. text in description
3. This flash message will be displayed:
     Project "tenant6" was saved
   Expected flash message is:
     Tenant "tenant6" was saved

Deletion of tenant:
1. Delete tenant6 created in previous step
2. This flash message will be displayed:
     Tenant "tenant6 desc updated": Delete successful
   Expected flash message is:
     Tenant "tenant6": Delete successful

Deletion of project:
1. Create new project
     name: project6
     description: project6 desc
2. Delete this project
3. This flash message will be displayed on screen:
     Tenant "project6 desc": Delete successful
   Expected flash message is:
     Project "project6": Delete successful

Additional info:
Comment 2 Pavol Kotvan 2016-01-14 06:24 EST
Created attachment 1114754 [details]
Case 2 screenshot
Comment 3 Pavol Kotvan 2016-01-14 06:25 EST
Created attachment 1114755 [details]
Case 3 screenshot
Comment 5 Chris Pelland 2017-08-21 09:05:37 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.
Comment 6 Chris Pelland 2017-08-21 09:08:14 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.