Bug 1298539 - login page contains unused html code
login page contains unused html code
Status: CLOSED WONTFIX
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI (Show other bugs)
2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3
Assigned To: sankarshan
Martin Bukatovic
:
Depends On:
Blocks: 1339994
  Show dependency treegraph
 
Reported: 2016-01-14 06:54 EST by Martin Kudlej
Modified: 2017-03-23 00:11 EDT (History)
4 users (show)

See Also:
Fixed In Version: rhscon-ui-0.0.19-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-23 00:11:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kudlej 2016-01-14 06:54:21 EST
Description of problem:
Login page contains HTML which is not visible and used. I think this code should not be there. Login page should stay simple as much as possible because its content is available for non authorized users.
For example there is hidden search input and other menu icons:
<nav class="collapse navbar-collapse">
    <ul class="nav navbar-nav navbar-right navbar-iconic" ng-controller="RequestsController as request">
		<li class="dropdown wrap">
			<form action="" autocomplete="on">
				<input class="search_textbox" id="search" name="search" type="text" placeholder="What're we looking for ?" />
				<button id="search_submit" class="search-btn" type="submit">
					<i class="fa fa-search"></i>
				</button>
			</form>
		</li>
		<li class="dropdown">
			<a data-toggle="dropdown" class="dropdown-toggle nav-item-iconic" href="" data-template="views/base/alert-dropdown.tpl.html"  data-animation="am-fade-and-slide-top" bs-dropdown="dropdown">
                <i class="fa fa-bell"></i>
                <span class="badge" style="position:relative;" ng-if="request.events.length>0" ng-bind="request.events.length"></span>
            </a>
		</li>
		<li class="dropdown">
			<a data-toggle="dropdown" class="dropdown-toggle nav-item-iconic" bs-dropdown="dropdown" href="" ng-click="request.getDiscoveredHosts();" data-template="views/base/discovered-hosts.tpl.html"
			data-animation="am-fade-and-slide-top" bs-dropdown="">
                <i class="fa fa-desktop"></i>
                <span class="badge" style="position:relative;" ng-if="request.discoveredHostsLength>0" ng-bind="request.discoveredHostsLength"></span>
                <div growl></div>
            </a>
		</li>
		<li class="dropdown">
			<a data-toggle="dropdown" class="dropdown-toggle nav-item-iconic" bs-dropdown="dropdown" href="" data-template="views/base/progress-dropdown.tpl.html"
			data-animation="am-fade-and-slide-top" bs-dropdown="">
                <i class="fa fa-flag"></i>
                <span class="badge" style="position:relative;" ng-if="request.tasks.length>0" ng-bind="request.tasks.length"></span>
            </a>
		</li>
		<li class="dropdown user">
			<a data-toggle="dropdown" class="dropdown-toggle nav-item-iconic" bs-dropdown="dropdown" href="" data-template="views/base/admin-dropdown.tpl.html"
			data-animation="am-fade-and-slide-top">
                <i class="fa fa-user"></i>
                <span class="caret"></span>
            </a>
		</li>
    </ul>
  </nav>

Version-Release number of selected component (if applicable):
rhscon-ui-0.0.6-0.1.alpha1.el7.noarch

How reproducible:
100%

Actual results:
There are hidden UI on login page which should not be there.

Expected results:
There are just visible and functional html on login page. Especially all hidden but functional parts like inputs and menus should be removed.
Comment 1 Dhivya Sivaprakasam 2016-02-16 01:28:08 EST
https://review.gerrithub.io/#/c/263269/
Comment 4 Martin Bukatovic 2016-07-01 07:16:16 EDT
Using rhscon-ui-0.0.42-1.el7scon.noarch

I still see the navbar elements in the source code of the login page.

>> ASSIGNED

Moreover, it seems that this BZ is a root cause of BZ 1339994 - login page
is polling RHSC 2.0 API: GET request asking for unmanaged_nodes[1] is send
every 10s (as shown in the BZ 1339994)

>> flagging BZ 1339994 blocked by this BZ

[1] https://rhsc.example.com:10443/api/v1/unmanaged_nodes

Note You need to log in before you can comment on or make changes to this bug.