Bug 1298573 - login page doesn't redirect to main page in case of valid cookie
login page doesn't redirect to main page in case of valid cookie
Status: CLOSED WONTFIX
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI (Show other bugs)
2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3
Assigned To: kamlesh
sds-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 08:07 EST by Martin Kudlej
Modified: 2017-03-23 00:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-23 00:10:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kudlej 2016-01-14 08:07:48 EST
Description of problem:
I think if user has valid session cookie login page can redirect to main page.

Version-Release number of selected component (if applicable):
rhscon-ui-0.0.6-0.1.alpha1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. login and check valid session cookie
2. go to login page in same browser
3. login page should be redirected to main page
Comment 1 Martin Bukatovic 2016-01-21 05:13:09 EST
Additional information: When user needlessly authenticates again because
of this BZ, the following entry appears in /var/log/skyring/skyring.log:

~~~
2016-01-21T11:08:45.132+01:00 ERROR    auth.go:143 Login] Already logged in
~~~

Note You need to log in before you can comment on or make changes to this bug.