Bug 129864 - enable, reject and accept do nothing
enable, reject and accept do nothing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-13 11:34 EDT by Patrice Dumas
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 18:42:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2004-08-13 11:34:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
enable, reject, accept and disable do nothing except echoing a strange
error message. The error message consists in the last 2 or 3 letters
of the command followed by : Don't know what to do!

For example:

[root@hermes root]# accept kfet
pt: Don't know what to do!
[root@hermes root]# reject kfet
ct: Don't know what to do!
[root@hermes root]# disable kfet
ble: Don't know what to do!
[root@hermes root]# 

Moreover reject doesnt seem to do anything:
[root@hermes root]# lpstat -t
scheduler is running
system default destination: kfet
device for couloir: socket://couloir:9100/
device for kfet: socket://kfet:9100/
couloir accepting requests since Jan 01 00:00
kfet accepting requests since Jan 01 00:00
printer couloir is idle.  enabled since Jan 01 00:00
printer kfet is idle.  enabled since Jan 01 00:00
        Ready to print.
[root@hermes root]# reject kfet
ct: Don't know what to do!
[root@hermes root]# lpstat -t
scheduler is running
system default destination: kfet
device for couloir: socket://couloir:9100/
device for kfet: socket://kfet:9100/
couloir accepting requests since Jan 01 00:00
kfet accepting requests since Jan 01 00:00
printer couloir is idle.  enabled since Jan 01 00:00
printer kfet is idle.  enabled since Jan 01 00:00
        Ready to print.
[root@hermes root]# 

I can print afterwards.

The printers were configured with:

[root@hermes root]# lpadmin -p kfet -m laserjet.ppd.gz -v
socket://kfet:9100 -o media=A4
[root@hermes root]# lpadmin -p couloir -m laserjet.ppd.gz -v
socket://kfet:9100 -o media=A4

lpr seems to print right, but a2ps has troubles. I'll fill another bug
report I don't think these are related issues.

Version-Release number of selected component (if applicable):
cups-1.1.20-11.1

How reproducible:
Always

Steps to Reproduce:
1. configure a printer with lpadmin
2. run reject
3.
    

Actual Results:  A weird error message:

[root@hermes root]# reject kfet
ct: Don't know what to do!

and nothing changed

Expected Results:  no such error messages and jobs for that printer
rejected.

Additional info:

I upgraded with yum from a redhat 9. On the redhat 9 there wasn't such
an issue. This issue could be particular to my setup, as nobody else
reported it. Or maybe running lpadmin isn't enough anymore to have a
working setup. I didn't used printconf/system-config-printer.
Comment 1 Tim Waugh 2004-08-13 11:37:37 EDT
I discovered this issue independently just today -- what a coincidence
-- and there is an easy fix known.  This probably needs an FC2 update
package.
Comment 2 Tim Waugh 2004-08-16 13:17:23 EDT
Please try the FC2 test update package cups-1.1.20-11.2.

http://www.redhat.com/archives/fedora-test-list/2004-August/msg00508.html
Comment 3 Patrice Dumas 2004-08-17 11:00:37 EDT
This seems fixed with that update.
Comment 4 Tim Fletcher 2004-09-08 12:52:25 EDT
The update never appears to have been released for x86_64 is there a
reason for this is (broken package etc) or is it an oversight?
Comment 5 Patrice Dumas 2004-09-08 13:11:19 EDT
It isn't released for i386 either. Maybe waiting for more feedback.
There is a testing update for x86_64, though, you migth want to
install and test it? 

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/2/x86_64/
Comment 6 Tim Waugh 2004-09-08 16:20:12 EDT
I have had *so* little feedback on the testing update it's just not funny.

PLEASE TEST IT and *TELL ME IF IT WORKS*. (Thanks.)
Comment 7 Tim Fletcher 2004-09-08 18:55:57 EDT
Appologies for miss reading the release status, I looked on my FC2
laptop and saw it had a more upto date version that the x86_64 server
in question so wrongly assumed that an update had gone out for i386. I
have installed it and have tested it with about 50 printers, including
enable / disable / reject on each printer.
Comment 8 Peter Åstrand 2004-09-14 05:09:45 EDT
Works for me. Thanks!
Comment 9 Neil Bird 2004-09-30 14:24:57 EDT
Yep, that seems to do the job OK.

Note You need to log in before you can comment on or make changes to this bug.