Bug 1298725 - initial-setup continues to run after 'successful' completion
initial-setup continues to run after 'successful' completion
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initial-setup (Show other bugs)
rawhide
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Kolman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 15:01 EST by Paul Whalen
Modified: 2016-02-22 15:08 EST (History)
3 users (show)

See Also:
Fixed In Version: initial-setup-0.3.39-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 15:08:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Whalen 2016-01-14 15:01:23 EST
Description of problem:
initial-setup remains enabled after 'successful' completion.

Version-Release number of selected component (if applicable):
initial-setup-0.3.38-1.fc24

How reproducible:
Everytime

Steps to Reproduce:
1. reproducible on both arm xfce image and x86 installation (spoke left incomplete for user)
2. enable initial-setup if needed (x86), reboot
3. complete all spokes, run 'systemctl status initial-setup' after logging in.

systemctl status initial-setup
● initial-setup.service - Initial Setup configuration program
   Loaded: loaded (/usr/lib/systemd/system/initial-setup.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Thu 2016-01-14 14:35:28 EST; 18min ago
  Process: 855 ExecStart=/usr/libexec/initial-setup/run-initial-setup (code=exited, status=1/FAILURE)
  Process: 827 ExecStartPre=/bin/plymouth quit (code=exited, status=0/SUCCESS)
  Process: 800 ExecStartPre=/bin/kill -55 1 (code=exited, status=0/SUCCESS)
 Main PID: 855 (code=exited, status=1/FAILURE)

Jan 14 14:35:27 localhost.localdomain initial-setup[948]: executing addons
Jan 14 14:35:27 localhost.localdomain initial-setup[948]: writing the Initial Setup kickstart file /root/initial-setup-ks.cfg
Jan 14 14:35:27 localhost.localdomain initial-setup[948]: finished writing the Initial Setup kickstart file
Jan 14 14:35:27 localhost.localdomain org.a11y.atspi.Registry[1266]: XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":9"
Jan 14 14:35:27 localhost.localdomain org.a11y.atspi.Registry[1266]: after 21 requests (21 known processed) with 0 events remaining.
Jan 14 14:35:28 localhost.localdomain logger[1433]: Initial Setup finished successfully, disabling
Jan 14 14:35:28 localhost.localdomain systemd[1]: initial-setup.service: Main process exited, code=exited, status=1/FAILURE
Jan 14 14:35:28 localhost.localdomain systemd[1]: Failed to start Initial Setup configuration program.
Jan 14 14:35:28 localhost.localdomain systemd[1]: initial-setup.service: Unit entered failed state.
Jan 14 14:35:28 localhost.localdomain systemd[1]: initial-setup.service: Failed with result 'exit-code'.

Service will remain enabled, and listed as failed.

systemctl --all --failed
  UNIT                  LOAD   ACTIVE SUB    DESCRIPTION
● initial-setup.service loaded failed failed Initial Setup configuration program
Comment 1 Dennis Gilmore 2016-01-25 10:42:47 EST
same results here. I did not complete user setup as i use freeipa and configure it after the system is up
Comment 2 Martin Kolman 2016-02-15 09:10:42 EST
I've just posted patch that should fix this for review.
Comment 3 Paul Whalen 2016-02-18 15:16:10 EST
Confirmed, working as expected with initial-setup-0.3.39-1. Thanks Martin!
Comment 4 Martin Kolman 2016-02-19 05:33:13 EST
(In reply to Paul Whalen from comment #3)
> Confirmed, working as expected with initial-setup-0.3.39-1. Thanks Martin!

Good to hear that! :)

Note You need to log in before you can comment on or make changes to this bug.