Bug 1298747 - SELinux is preventing gst-plugin-scan from using the 'dac_override' capabilities.
SELinux is preventing gst-plugin-scan from using the 'dac_override' capabilit...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:36ffed17a1164879967def1535c...
:
: 1307123 1315429 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-14 17:24 EST by Geezus
Modified: 2016-05-05 09:13 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-15 08:59:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geezus 2016-01-14 17:24:55 EST
Description of problem:
SELinux is preventing gst-plugin-scan from using the 'dac_override' capabilities.

*****  Plugin dac_override (91.4 confidence) suggests   **********************

If you want to help identify if domain needs this access or you have a file with the wrong permissions on your system
Then turn on full auditing to get path information about the offending file and generate the error again.
Do

Turn on full auditing
# auditctl -w /etc/shadow -p w
Try to recreate AVC. Then execute
# ausearch -m avc -ts recent
If you see PATH record check ownership/permissions on file, and fix it, 
otherwise report as a bugzilla.

*****  Plugin catchall (9.59 confidence) suggests   **************************

If you believe that gst-plugin-scan should have the dac_override capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep gst-plugin-scan /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Objects                Unknown [ capability ]
Source                        gst-plugin-scan
Source Path                   gst-plugin-scan
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-158.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.3.3-300.fc23.x86_64 #1 SMP Tue
                              Jan 5 23:31:01 UTC 2016 x86_64 x86_64
Alert Count                   8
First Seen                    2016-01-12 13:19:05 CST
Last Seen                     2016-01-12 13:19:08 CST
Local ID                      84bde419-16ff-401d-bed3-d50ec79f0063

Raw Audit Messages
type=AVC msg=audit(1452626348.119:645): avc:  denied  { dac_override } for  pid=9688 comm="totem-video-thu" capability=1  scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tclass=capability permissive=0


Hash: gst-plugin-scan,thumb_t,thumb_t,capability,dac_override

Version-Release number of selected component:
selinux-policy-3.13.1-158.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.3.3-300.fc23.x86_64
type:           libreport

Potential duplicate: bug 823210
Comment 1 Daniel Walsh 2016-01-15 08:59:45 EST
You are running graphics tools as root, this is not supported and is considered dangerous.
Comment 2 Geezus 2016-02-12 13:38:09 EST
*** Bug 1307123 has been marked as a duplicate of this bug. ***
Comment 3 Geezus 2016-03-07 12:27:05 EST
*** Bug 1315429 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.